summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-09 08:08:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-09 08:38:20 +0200
commitb8e66b32581af66cb15765833628f5237f9633f8 (patch)
treee65d1eccf45870303526b80c151fbf8b6e9f506f /dev-python
parentdev-python/identify: Bump to 2.2.14 (diff)
downloadgentoo-b8e66b32581af66cb15765833628f5237f9633f8.tar.gz
gentoo-b8e66b32581af66cb15765833628f5237f9633f8.tar.bz2
gentoo-b8e66b32581af66cb15765833628f5237f9633f8.zip
dev-python/botocore: Bump to 1.21.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.38.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 15bf9eef0939..c46ffc0def8b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.21.28.tar.gz 8079306 BLAKE2B 26dce445746a9da1b0cf62b622597396f9b
DIST botocore-1.21.35.tar.gz 8122175 BLAKE2B 976ceaeb93a838337403b334e4ff4747e725cb473859031b86bcd6f87313a2c8e799a11f65f7e5efe5f4c063010fd55f4c012866be92db6e974c2293bf499a64 SHA512 7d94e35b027c01329eaf1b7d0f14f860359fdcebca0d0b842b87aeb5af61ee1fa5438f6d316b5d5b9a3f262fe8d24da5d0c6546679f3789ce09da17205aae162
DIST botocore-1.21.36.tar.gz 8120799 BLAKE2B 3150e1efeca3173001f22e5e577ec4d9872af93608b3854f184455d11c1132bede7626b4f2a1ee79a70c1029578cac908914ef17e9d8675af1556454c270cb34 SHA512 1e69693580ebb311bc6be76ce92a11e3ecd33872dcd72c7add6dae696b231a39a3db6a6290930585445f442b7a5ba09445f0f176cd1d1ff21dde3efd054c0f0b
DIST botocore-1.21.37.tar.gz 8123057 BLAKE2B 0e7c50bd5263db120f051e3d14c1a2f71db679c69cf22ca22f31a4e971d0aafe583b62e3d04083b5646663a87055bef73369d34b9ae825da25fe2bf4a76e58de SHA512 a81604b173216bce93b81a874b5f4defc84c9d1766f90c0fcd8b2ce9fa03867f11a08a6405f5e70006f10645a3729c2843c3f9c59bf37f901a5c07e73865f05c
+DIST botocore-1.21.38.tar.gz 8145897 BLAKE2B fef3847b2f2b1423438ac7922d850d132c313bb2c1eac4c73b31ee48100f1096c218730b30b2255f14bdbcab945a5dc851898cc00c89b692c45404e6c2f902c2 SHA512 2f9d32424f6f8e9829e7c111a83ec8176c72647be9253057cacc6fb89a2f3c2bded8d81d7704df45998daa4721a3391a6d510ac8e5052eb7caf7323f37be95c9
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.38.ebuild b/dev-python/botocore/botocore-1.21.38.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.38.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}