summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-16 01:51:09 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-16 10:27:39 +0100
commitb9e07140ae13284b7501e02e1ce24e12f27fd9c5 (patch)
tree1beb0e87d898cebe90f9624ac7accfbe27fa821e /dev-python
parentsys-apps/man-db-2.7.6.1-r1: stable on alpha (diff)
downloadgentoo-b9e07140ae13284b7501e02e1ce24e12f27fd9c5.tar.gz
gentoo-b9e07140ae13284b7501e02e1ce24e12f27fd9c5.tar.bz2
gentoo-b9e07140ae13284b7501e02e1ce24e12f27fd9c5.zip
dev-python/minidb: bump to 2.0.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3496
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/minidb/Manifest1
-rw-r--r--dev-python/minidb/metadata.xml1
-rw-r--r--dev-python/minidb/minidb-2.0.2.ebuild28
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/minidb/Manifest b/dev-python/minidb/Manifest
index 23002d4b569f..e4c0ebe4c82d 100644
--- a/dev-python/minidb/Manifest
+++ b/dev-python/minidb/Manifest
@@ -1 +1,2 @@
DIST minidb-2.0.1.tar.gz 13848 SHA256 be894fc4e68e3ce9b84b3992f12fbbea5051d3c2a11019b1da463099f24725f5 SHA512 98be264ba669ef08f180c469ca8375540436244228ee4e0c4e4b0511425b909eb4c64dc812a27d0b490af5972e0897538f905590b7d2dd19f6fdd160280a6b4b WHIRLPOOL a209d44f26add8ebae0ad142c94fdfcd4698b80d4f7e491ad16d36a4704f8fa9f3e8649aead9b268cb80055c6ae9f4691e6428979e048907a79caef8165fb864
+DIST minidb-2.0.2.tar.gz 13928 SHA256 43d59231556e9ed43d88c8c1ffcca30886b4db6436625599eeeb22bb9f74ab2b SHA512 92879d6df61b0f9f72f9fe8f1cf38d559477983c6bba8c88ed02289570daff02f6f8d7010c0a95ffce049ab67be69323c47caefdfe3a8b008038377235ed9a5f WHIRLPOOL 3ec87fc16ca02c817c70917a8bb0b3da5f12aeaf0b54827551b27a1549ad8daad635d88a81a14730c9deea50ca582f201cbef83ca929a14d91b1b722d5865a58
diff --git a/dev-python/minidb/metadata.xml b/dev-python/minidb/metadata.xml
index 91441069f1b9..0d15c314bd98 100644
--- a/dev-python/minidb/metadata.xml
+++ b/dev-python/minidb/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
diff --git a/dev-python/minidb/minidb-2.0.2.ebuild b/dev-python/minidb/minidb-2.0.2.ebuild
new file mode 100644
index 000000000000..48fb21881d4a
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}