summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-30 22:20:45 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-30 22:20:45 -0400
commitba613e9363f949cc2d185a01ebdb0ea418d57193 (patch)
tree6583ac5b385da04f45b531b8e097607605d799da /dev-python
parentdev-python/pygments: fix build with USE="doc" (diff)
downloadgentoo-ba613e9363f949cc2d185a01ebdb0ea418d57193.tar.gz
gentoo-ba613e9363f949cc2d185a01ebdb0ea418d57193.tar.bz2
gentoo-ba613e9363f949cc2d185a01ebdb0ea418d57193.zip
dev-python/pygments: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.1.1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 2369915a0096..36ccac029d6c 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,2 +1 @@
-DIST Pygments-2.1.1.tar.gz 2114190 BLAKE2B b0e5d5a62849c97aaac6f0edf26230d5573715fb759667ca888372666634ab68da4580b1337ec4ada013b643411c221c572651c6fca6745b976794d5c6246e5d SHA512 7eb35865074f573ef7d41a1f1ee7576a83c32855018d03570eb70fd6864ddfbbc3f93ae082c4ac7e4a274a0ef387ea4ccb0909423e01efb6bb8e4fefea8f2807
DIST Pygments-2.2.0.tar.gz 2113944 BLAKE2B 58d5f2fa0e6d97f5b7d7a17314b82ef219f23b72f8da49b4f8ce9b892d54ffbc1b490e87e87efe8d727dab297f775d0d8abfc4a31a734c5a7f8df885e5eda82f SHA512 cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29
diff --git a/dev-python/pygments/pygments-2.1.1.ebuild b/dev-python/pygments/pygments-2.1.1.ebuild
deleted file mode 100644
index 82cfec6da8f3..000000000000
--- a/dev-python/pygments/pygments-2.1.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1 bash-completion-r1 vcs-snapshot
-
-MY_PN="Pygments"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pygments is a syntax highlighting package written in Python"
-HOMEPAGE="http://pygments.org/ https://pypi.org/project/Pygments/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- virtual/ttf-fonts )"
-# dev-texlive/texlive-latexrecommended
-# Removing / commenting out this dep. I can find no mention of it in tests other than
-# importing pygment's own tex module. If it's there and I missed it just uncomment and re-add
-# Tests pass without it
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}"/ || die
- # With pypy3 there is 1 error out of 1556 tests when run as is and
- # (SKIP=8, errors=1, failures=1) when run with 2to3; meh
- nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
- newbashcomp external/pygments.bashcomp pygmentize
-}