summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-09 07:57:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-09 08:38:18 +0200
commitbab3e09a0a944cfc4fc0bad2c3a2b678ea2da4a1 (patch)
tree1701a9183df8734b73573c5926f9928d4e91fbcb /dev-python
parentapp-emulation/podman: Update GIT_COMMIT (diff)
downloadgentoo-bab3e09a0a944cfc4fc0bad2c3a2b678ea2da4a1.tar.gz
gentoo-bab3e09a0a944cfc4fc0bad2c3a2b678ea2da4a1.tar.bz2
gentoo-bab3e09a0a944cfc4fc0bad2c3a2b678ea2da4a1.zip
dev-python/hypothesis: Bump to 6.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.20.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e399ab95f5ab..133edcf346ef 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.14.9.tar.gz 9138640 BLAKE2B 3cda0edace7b3a1c373bdd61267
DIST hypothesis-python-6.17.4.tar.gz 9144209 BLAKE2B b110e355b34f386c51e9edeb2589bf11e5d0b574ee7e97437f9eba9ec7d8e823e68ad1e4f5911a1e78f3d5a316f59056301b0238c4b6a8cdcb21e46ea434686c SHA512 95eeadc1655d249008897035660af54f66e8ea78fea78d1069dbddb979505e003d1bdb971371769e90af4a7bc5f96ee0c42a6c14bc42e56677d4f89f39985d41
DIST hypothesis-python-6.18.0.tar.gz 9145660 BLAKE2B 6fb47aeb134363e50944d08f0658245d9cc5190260e56cc16c394499df0bcf3739fd69c22bcfce6f3b290a1ecd9bdc8ac6bfd7c5f2efd4b00694b81d7dba062d SHA512 069deaa91b7dc7244c8fccb046e384c60009365418dfb7f76ed75428446a731ec860613201d0657c2c8b3b29e4fce3c403a93aa082f48b072471f919b7a1af5a
DIST hypothesis-python-6.19.0.tar.gz 9146087 BLAKE2B 11cf1e76735f2d57ee793c131a055c0e349bf7a39b072ac33914bcc371d44a607866ec617d2f955779fe99922f968b8da571fea87c45db72583e3ea2026000a5 SHA512 b641938c6f9b5603bb7b72ba1106da16bdcd0528de34317afdc4099bbfa1bfec90e76fbf14dc7cfc773fb02c3fa3b4bcfeea7f3788884cbefb51751f02879f9c
+DIST hypothesis-python-6.20.0.tar.gz 9146238 BLAKE2B 88009c7369209f8781644a975587d757ecf83e9e84e650fd2f8e88b5e4e1d078dd0639e49a9055c4390c0aba96a661561ff5858bf628036d097c614b7d9fc45a SHA512 6c139c78b75c5b8408345d654e6d638f4f2b0f1567bcb05c430e396d3dbf40fde7e3f6a6af4eea75b2387d395e8ee2a5eb11eabd3183c4eff0a35979aed1bcba
diff --git a/dev-python/hypothesis/hypothesis-6.20.0.ebuild b/dev-python/hypothesis/hypothesis-6.20.0.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.20.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}