summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 12:13:48 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 12:38:00 +0100
commitbb3662ace6cc8ead4655d5ec2f334d89aaa51edd (patch)
tree42d58f57f68a39b6228271103a91088adcae27f7 /dev-python
parentmetadata.xml: Correct broken text in ja longdescriptions (diff)
downloadgentoo-bb3662ace6cc8ead4655d5ec2f334d89aaa51edd.tar.gz
gentoo-bb3662ace6cc8ead4655d5ec2f334d89aaa51edd.tar.bz2
gentoo-bb3662ace6cc8ead4655d5ec2f334d89aaa51edd.zip
dev-python/urwid: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-1.3.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 925335d72db3..4f45224912df 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1,2 +1,3 @@
DIST urwid-1.2.2.tar.gz 585025 SHA256 e122e2dee122314f5626945af4dbe15bf3de9f318c552a4c0b68c1c480852d92 SHA512 10d0271e52b28aff3350d3342cd9b1c8fab819f3619cce77286b2545b74dd967f0466e98dfbfef1189b3ab6b38392168367d75c768b0f5b8058666b0211706a5 WHIRLPOOL 69556a721d89f6a6b82664bf5eaa10a21c49d15f9b8e6e6be4ba31ce5e2317fd0ecebfa3d93b008f9bd93f10504161d93e1827d696a6c1baa09939ac628f027d
DIST urwid-1.3.0.tar.gz 580922 SHA256 29f04fad3bf0a79c5491f7ebec2d50fa086e9d16359896c9204c6a92bc07aba2 SHA512 2743488f2815e6abff8bf2450b2a3d5756fa026587512cf29a3850be0e585d7c2dd4d50fda7bf1589de32eed93637ac0ee88f002de4b9bee0a72dc6574ef6103 WHIRLPOOL c276c26deb557b1c4b8f9f49f7f6c10e0e5a169bc3a1b9c3933a948c313897da4ebdb0520b7fc3d0a301cbc5743a1d79a20e112d852e74b50910db6ea1a4e99e
+DIST urwid-1.3.1.tar.gz 588549 SHA256 cfcec03e36de25a1073e2e35c2c7b0cc6969b85745715c3a025a31d9786896a1 SHA512 8b505d38f3a0c04bbf527b324dc36212f2580213dd55eca61c66705d3beaac4f074c39aaa0f4f71add1fe5f3fce4c4c6dc88dd1e981b04bac6d52195d7a3f0ed WHIRLPOOL ff908dfad8e893fd51510168433a6bd63fe1edc38dde65664994f5eb3343e8fe818c4c1b9d5c296d3f3fdc93e2df7a3809f661e52322e6e69e163484b0e38944
diff --git a/dev-python/urwid/urwid-1.3.1.ebuild b/dev-python/urwid/urwid-1.3.1.ebuild
new file mode 100644
index 000000000000..9c50621984a0
--- /dev/null
+++ b/dev-python/urwid/urwid-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="http://urwid.org/ https://pypi.python.org/pypi/urwid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.0-sphinx.patch )
+
+python_compile_all() {
+ if use doc ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ 2to3 -nw --no-diffs docs/conf.py || die
+ fi
+ cd docs
+ sphinx-build . _build/html || die
+ fi
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}