summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-08 06:33:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-08 06:55:33 +0100
commitbbae9a3975b6c9a559b2f8972e634bacb6549ded (patch)
treeec867a49aadec177109cc662e853a9ad22c8b320 /dev-python
parentdev-python/pymdown-extensions: Bump to 9.8 (diff)
downloadgentoo-bbae9a3975b6c9a559b2f8972e634bacb6549ded.tar.gz
gentoo-bbae9a3975b6c9a559b2f8972e634bacb6549ded.tar.bz2
gentoo-bbae9a3975b6c9a559b2f8972e634bacb6549ded.zip
dev-python/asteval: Bump to 0.9.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/asteval/Manifest1
-rw-r--r--dev-python/asteval/asteval-0.9.28.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/asteval/Manifest b/dev-python/asteval/Manifest
index 0df41c9175cd..30f440ae81e5 100644
--- a/dev-python/asteval/Manifest
+++ b/dev-python/asteval/Manifest
@@ -1 +1,2 @@
DIST asteval-0.9.27.tar.gz 41789 BLAKE2B 6db628dfc90479b605370e6cd4c3eb27a6fdabd2422016aab200ddb217fc5459df77ae99397145511600ae4a79e259c9e7c75c3be50bf5201e08915a76ca5571 SHA512 b56fb81f1055ab66868084edb89775ec87f40ee45563531bf4661ee65656e777b388856e691740af60b4a3891e872683768ac590a78fda2fed9173e613aa7263
+DIST asteval-0.9.28.gh.tar.gz 39784 BLAKE2B 99c74b7d9f01de07dc568a5276852e66dd6c520c45af91b9471bc6f9485ac50bc20bc96df804188a610bac01e8e34534e8bb157784afd6b1799ca97280e4c5ed SHA512 108652594a0eaaf009b8652ced9000ef7454d8f33fe844e74fb1dd78a2ead42a60d5ba68845c8d9c9d8570a70b5958519a6350d77c66257a7fa18de23802c3b0
diff --git a/dev-python/asteval/asteval-0.9.28.ebuild b/dev-python/asteval/asteval-0.9.28.ebuild
new file mode 100644
index 000000000000..f2a91b2237be
--- /dev/null
+++ b/dev-python/asteval/asteval-0.9.28.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://newville.github.io/asteval/
+ https://github.com/newville/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/newville/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}