summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-27 14:31:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-27 14:31:05 +0300
commitbc4e6cdfa0d748afb83c1bcd69bd4bdc89e983b3 (patch)
treeba0260a7a1c991cff0cfbe2bd4f2a581f11fa284 /dev-python
parentmedia-sound/pulseaudio-daemon: USE=tcpd requires libpulse[tcpd] (diff)
downloadgentoo-bc4e6cdfa0d748afb83c1bcd69bd4bdc89e983b3.tar.gz
gentoo-bc4e6cdfa0d748afb83c1bcd69bd4bdc89e983b3.tar.bz2
gentoo-bc4e6cdfa0d748afb83c1bcd69bd4bdc89e983b3.zip
dev-python/requests-cache: cleanup deps
- Add optional dependencies - Add missing test deps - Add missing rdeps Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-cache/requests-cache-0.8.1-r1.ebuild (renamed from dev-python/requests-cache/requests-cache-0.8.1.ebuild)17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/requests-cache/requests-cache-0.8.1.ebuild b/dev-python/requests-cache/requests-cache-0.8.1-r1.ebuild
index 61afa9af0454..b5921df49217 100644
--- a/dev-python/requests-cache/requests-cache-0.8.1.ebuild
+++ b/dev-python/requests-cache/requests-cache-0.8.1-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
+inherit distutils-r1 optfeature
HOMEPAGE="
https://pypi.org/project/requests-cache/
@@ -22,16 +22,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
dev-python/cattrs[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
>=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
>=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
BDEPEND="
test? (
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
)"
distutils_enable_tests pytest
@@ -52,3 +56,12 @@ python_test() {
local -x USE_PYTEST_HTTPBIN=true
epytest
}
+
+pkg_postinst() {
+ optfeature "redis backend" "dev-python/redis-py"
+ optfeature "MongoDB backend" "dev-python/pymongo"
+
+ optfeature "JSON serialization" "dev-python/ujson"
+ optfeature "YAML serialization" "dev-python/pyyaml"
+ optfeature "signing serialized data" "dev-python/itsdangerous"
+}