summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-10 20:49:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-10 20:50:14 +0100
commitbc975f7e46be8974c00fcbd1fb117bd5e13646b9 (patch)
tree9bfc9203f20476e125f0a69207d9ace4677d96d9 /dev-python
parentdev-python/readme_renderer: Remove old (diff)
downloadgentoo-bc975f7e46be8974c00fcbd1fb117bd5e13646b9.tar.gz
gentoo-bc975f7e46be8974c00fcbd1fb117bd5e13646b9.tar.bz2
gentoo-bc975f7e46be8974c00fcbd1fb117bd5e13646b9.zip
dev-python/pytest-xdist: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 12a7c91eab0f..a6860576c9e8 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1 @@
-DIST pytest-xdist-2.4.0.tar.gz 67199 BLAKE2B bba867bfbd1e161ada2157fdb5a10f929fefed959b64afef74453206d91e5014abaaa1363ac9adbc89ed476a841607f6830781817842b9be119a09bda7278b91 SHA512 2d2da6aaa8da07a28d7c6c81a0044493b7d0d1a68921e7ec94cfd2f698eaa5594b6da4d82524804637d5cc061fbe19034f3c65a07ee5a0c906170856edc3d383
DIST pytest-xdist-2.5.0.tar.gz 72455 BLAKE2B 4d7427e8a7d85d7b0dcae2697fae0f51913a3a2414fabbb192a8e3938431f5f121677dd43adecfb1fc7f3dd6feb94901e28b0a96787a2c2eadc1504aac55068f SHA512 22da4db7cdd6173fb8377b6adc30b5617ccb0bb308cb5d30980484dd7ddff87cf2a485ae8522c7957d8954dd2f8a5542b9f63b0fa7184cc44e50dbafc3f4e909
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
deleted file mode 100644
index 50b0a8e3c26e..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# pytest-xdist >= 2 fails with pytest < 6
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- distutils_install_for_testing
- epytest
-}