summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-22 08:19:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-22 09:07:01 +0100
commitbce2e1629fdc281364455a22767cb598f30a1eb5 (patch)
treefeedbae7490bca04fa78666e5aa3faf6a3ce0be8 /dev-python
parentdev-lang/python: Bump to 3.8.7 (diff)
downloadgentoo-bce2e1629fdc281364455a22767cb598f30a1eb5.tar.gz
gentoo-bce2e1629fdc281364455a22767cb598f30a1eb5.tar.bz2
gentoo-bce2e1629fdc281364455a22767cb598f30a1eb5.zip
dev-python/aiorpcX: Bump to 0.18.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.18.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 5988ae20fe58..6c03ad241fa9 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -1 +1,2 @@
DIST aiorpcX-0.18.4.gh.tar.gz 65500 BLAKE2B 8c84ace1e2bc974e68702e25efe126f7f69dd7451f438ccd924ee8be3c0cccc5c9b3d116bf2d0a755b013bdfe61a398d856031970e5ae82b571af09551231bed SHA512 d4df1343f575af72dff31f1794485c0cbb5b6c31d6d933b07cc8375a1418ad4fb81b2649b3c60adaaeab75b7a5d959838accc38269373310eb07895acf4c9496
+DIST aiorpcX-0.18.5.gh.tar.gz 65622 BLAKE2B 68b91e2cfb869c6971efb525fd35132c38ab9092362944fa77476bdb33f076f8415a079d97238e2c4ffbc6c9df596b468c2b6640389a11d1607b1a99aa8dc68d SHA512 5eb8417ce2ffb70208aec79e44ee0d8671c4cf86745f2d8061cf013c4ad17f83db68ed3ed43ef61df196e4ef073a21f9a4e22df46b00ce3054babf98dfcd1eaf
diff --git a/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
new file mode 100644
index 000000000000..5daef298f5af
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest