summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-20 14:20:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-20 14:23:43 -0500
commitbd138cdacda22f6bd2d98fd4e862996faeeea14f (patch)
treea2effc6c12977cac5d5275dda2b63f975332c313 /dev-python
parentdev-python/keystoneauth: 4.0.0 add py36 flag (diff)
downloadgentoo-bd138cdacda22f6bd2d98fd4e862996faeeea14f.tar.gz
gentoo-bd138cdacda22f6bd2d98fd4e862996faeeea14f.tar.bz2
gentoo-bd138cdacda22f6bd2d98fd4e862996faeeea14f.zip
dev-python/openstacksdk: 0.46.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/openstacksdk/Manifest1
-rw-r--r--dev-python/openstacksdk/openstacksdk-0.46.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/openstacksdk/Manifest b/dev-python/openstacksdk/Manifest
index 667dda668a8b..a452e80a8c0c 100644
--- a/dev-python/openstacksdk/Manifest
+++ b/dev-python/openstacksdk/Manifest
@@ -1 +1,2 @@
DIST openstacksdk-0.36.0.tar.gz 887545 BLAKE2B 8a207e5d3a2c6989a1e7c881beaa35dca4617569eeb2efec5f917f4310a6e49549b3ddc9f8106566b7b1e620b2aab38507f92063f68e326f234166a5ea7b267b SHA512 e95cb7c626f8bdd0064ed69d767dc1d53742d9d7a0d6196058453113ddcab3bdd903a1ef7455a2f9fe4335733793c927a00fe333099ba142ef69945a287d3983
+DIST openstacksdk-0.46.0.tar.gz 928650 BLAKE2B f1cf41cc63efb0824ada0c9ac5fea2c1e9b7bc32482df612ba655c6bc94c707e4472c0a5995609914c4e73531aa730a28ee9612a2058a3867d7980581244e20c SHA512 188bb2b2ae9fd3100aa64356d282bc6402c6f175371d8b514ed753f1dd2b1774e3bab22ca45df455fbb7d813236012c0c5174578a84d3f87a3390821f888d709
diff --git a/dev-python/openstacksdk/openstacksdk-0.46.0.ebuild b/dev-python/openstacksdk/openstacksdk-0.46.0.ebuild
new file mode 100644
index 000000000000..c6694550a51b
--- /dev/null
+++ b/dev-python/openstacksdk/openstacksdk-0.46.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of libraries for building applications to work with OpenStack."
+HOMEPAGE="https://github.com/openstack/python-openstacksdk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requestsexceptions-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-1.16[${PYTHON_USEDEP}]
+ !~dev-python/jsonpatch-1.20[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/munch-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-4.4.1[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.0[${PYTHON_USEDEP}]
+"