summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-05-19 13:11:41 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-05-19 13:11:41 +0900
commitc0253ea90aa03327fad4e4341cdd0d38a6dd24a5 (patch)
tree3d1f48e89cacb6e0ff9c3e74eeda1a85987a83b7 /dev-python
parentsys-devel/automake: bump to EAPI5. Rework APIVERSION and pkgvdatadir. (diff)
downloadgentoo-c0253ea90aa03327fad4e4341cdd0d38a6dd24a5.tar.gz
gentoo-c0253ea90aa03327fad4e4341cdd0d38a6dd24a5.tar.bz2
gentoo-c0253ea90aa03327fad4e4341cdd0d38a6dd24a5.zip
dev-python/llvmlite: disable libstdc++ static linking.
Bug: 580898 Upstream-Bug: https://github.com/numba/llvmlite/issues/93 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/llvmlite/llvmlite-0.10.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/llvmlite/llvmlite-0.10.0.ebuild b/dev-python/llvmlite/llvmlite-0.10.0.ebuild
index 4b8f23fe69b4..91e898657929 100644
--- a/dev-python/llvmlite/llvmlite-0.10.0.ebuild
+++ b/dev-python/llvmlite/llvmlite-0.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -28,7 +28,8 @@ DEPEND="${RDEPEND}
dev-util/cmake"
python_prepare_all() {
- sed -i -e 's/-flto$/-flto -fPIC/' ffi/Makefile.linux || die
+ sed -i -e 's/-flto$/-flto -fPIC/' \
+ -e 's/-static-libstdc++ //' ffi/Makefile.linux || die
# disable test using installed instance to read version info
sed -e 's:test_version:_&:' -i llvmlite/tests/test_binding.py || die