summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-12 13:45:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-12 14:25:45 +0200
commitc2573621f2cf8d03eb11cd9539590c7fa3a0da56 (patch)
tree394bdc8ef203a1803186b7cd600bbedb261fc6a7 /dev-python
parentwww-client/seamonkey: Use upstream rust-1.45 patch (diff)
downloadgentoo-c2573621f2cf8d03eb11cd9539590c7fa3a0da56.tar.gz
gentoo-c2573621f2cf8d03eb11cd9539590c7fa3a0da56.tar.bz2
gentoo-c2573621f2cf8d03eb11cd9539590c7fa3a0da56.zip
dev-python/osrf_pycommon: add missing test dep
Closes: https://bugs.gentoo.org/736826 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
index 5766d731686f..d38cfc41188e 100644
--- a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
+++ b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
@@ -13,12 +13,16 @@ SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-RESTRICT=""
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="dev-python/mock[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
PATCHES=( "${FILESDIR}/str.patch" )
distutils_enable_tests pytest