summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:02:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:43:45 -0500
commitc25817fd76883431ed606bcf9e46e1fc02ddede3 (patch)
tree3e2fd80a8986c3a5100c446333c4e189abffba37 /dev-python
parentdev-python/chai: add arm64 and py37 support (diff)
downloadgentoo-c25817fd76883431ed606bcf9e46e1fc02ddede3.tar.gz
gentoo-c25817fd76883431ed606bcf9e46e1fc02ddede3.tar.bz2
gentoo-c25817fd76883431ed606bcf9e46e1fc02ddede3.zip
dev-python/arrow: 0.13.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/arrow/Manifest1
-rw-r--r--dev-python/arrow/arrow-0.13.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/arrow/Manifest b/dev-python/arrow/Manifest
index 77a8429ef79f..e15d700352ac 100644
--- a/dev-python/arrow/Manifest
+++ b/dev-python/arrow/Manifest
@@ -1,2 +1,3 @@
DIST arrow-0.10.0.tar.gz 86506 BLAKE2B 3971e2aa4cefe70ce84267830800bd80bedb68caf3bd595614ac6bd77051bdff7c0e33ee09d569f4bcb9991255050b533464ade12c0d850a1d46dab3f65f03bd SHA512 a2baa23f1424b21506f3b664f0ef02d09f91b9cfaf6e0badfa544f42c750ed51136ae0e8910ac24207c0265a1b233f10a6f3cbafee3124b5f5c4fd965cfd01c0
DIST arrow-0.12.1.tar.gz 65356 BLAKE2B 671f1094bc71b4ab03a967929cd81cff46e0b48d509ef82827e28403eee3a92a8380a4e4903599ae3f2e2813ebe3b47a46846e32d98f78eb5866c643999e3a79 SHA512 f18449d3629ff5630aa77f6068e7cd3e2ee32ba35e1d0d972b03fff1dd817d2d936a38cdde45b2b8f218df5c1ce3e316404e33103d8bc82af9bcc377e37afb09
+DIST arrow-0.13.1.tar.gz 148509 BLAKE2B 7a47f8886cc2f50f6dda682daab37c599aad15c7e4a0c76b1324f9fe3a1b8168e3a2b29352bdc9c4daf0fa3b3843fa919d5256997c673bcb24ca033312242b60 SHA512 4933e02fe4ef7a632d55e5c6d2cbcefe6840467c809e0377be92f02d0dc10b5b2421cea2be7ddd5158236ec80f44848125253bfeef5a2ae635a3b9c5761fa105
diff --git a/dev-python/arrow/arrow-0.13.1.ebuild b/dev-python/arrow/arrow-0.13.1.ebuild
new file mode 100644
index 000000000000..6210fdb2d8a5
--- /dev/null
+++ b/dev-python/arrow/arrow-0.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python{3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Better dates and times for Python"
+HOMEPAGE="https://github.com/crsmithdev/arrow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/backports-functools-lru-cache[$(python_gen_usedep 'python2*')]"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/chai[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_prepare() {
+ sed -i -e "/with-coverage/d" setup.cfg || die
+}
+
+python_test() {
+ nosetests -v || die
+}