summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 22:54:24 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-27 00:34:24 +0100
commitc3d03c15e9c7d94fed00f139b39afdc2d9ccf8d8 (patch)
treedf474cb7ad9b2927e58b0f8f24f7be587e29732a /dev-python
parentdev-python/botocore: Bump to 1.20.39 (diff)
downloadgentoo-c3d03c15e9c7d94fed00f139b39afdc2d9ccf8d8.tar.gz
gentoo-c3d03c15e9c7d94fed00f139b39afdc2d9ccf8d8.tar.bz2
gentoo-c3d03c15e9c7d94fed00f139b39afdc2d9ccf8d8.zip
dev-python/boto3: Bump to 1.17.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.39.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1a0115f385d1..86446d59e715 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -21,4 +21,5 @@ DIST boto3-1.17.34.tar.gz 353010 BLAKE2B a50c6a7d5fa6cf0336fe69d5a78d3dd5b651f6b
DIST boto3-1.17.35.tar.gz 353497 BLAKE2B cf250901bfd67254c91dc468678d5935f076e37f5ead8a57bd8083ded3a0f24fbfa078b220c8c93310f2a75690226d374063ad9d0e022d39c2aaeab844e00bd3 SHA512 2d26f0009f4d3cd7a39c1b82426cfc3be18210ba7effaa31ce5ff0e1aa4ec26d0854f235f3e15be9db853242d348095c0c4691fd05a39921c25e948b4b1fef19
DIST boto3-1.17.36.tar.gz 353804 BLAKE2B e7a863dc2b9761a15191e43dd32f50243934d163b1a2b3a08577579a5b5ff4496062699a2287ce8cc3445e8ffbda0ddcf9e4c24b98d57a43153cb0d0fac4b695 SHA512 a786499b2147ce6b2920230b9700fe0941b332290675e5897ad94b15d262452e93f9bcaf56f676f52eeea383269af553b95e478d9b554b3596721e578dc6160d
DIST boto3-1.17.38.tar.gz 354416 BLAKE2B ac29b9bb2d589170567b0bf42ef7e3404bed83f9a5f5795b4468cd516c1f4e25c0f47e28e1c7f0dbbeb564782af32ae24c4a7429949f1e092045b974bcbfd96c SHA512 558a75f5e855997e98e20eebeb410fb2f7b125eb5c908e5aab873b89956d3c18be75d32c14a44e1cc7e838bb2ae1fdf37a1b4e4697bb311f4d47dc85e4e57831
+DIST boto3-1.17.39.tar.gz 354720 BLAKE2B bd5f9f676c346efc9264e42e802d0c5af5a3674cd4693019d39409e11958947c4a19982ce8572cc1be400f604b85428f6e964df175a71c35ffe11023b19cf733 SHA512 e12c08d06f68900291b36c71252d613a3a26298bdb9c665a1378ab5d26eacd65b496057aee74fedab6d5d955312d9225e63f7e0f1438d8fa739c2c1581d62297
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.39.ebuild b/dev-python/boto3/boto3-1.17.39.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.39.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}