summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-05-24 12:42:12 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-05-24 12:42:36 -0700
commitc40f558a9c6450e2c4ea5acb90f0a51510937223 (patch)
tree569a1f42d7871eb8e35f913b5260dcb8d5bbb9c7 /dev-python
parentdev-python/responses-0.13.2: Add py310 (diff)
downloadgentoo-c40f558a9c6450e2c4ea5acb90f0a51510937223.tar.gz
gentoo-c40f558a9c6450e2c4ea5acb90f0a51510937223.tar.bz2
gentoo-c40f558a9c6450e2c4ea5acb90f0a51510937223.zip
dev-python/flit: Version bump, fix dep in 2.1.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/files/flit-3.2.0-tests.patch12
-rw-r--r--dev-python/flit/flit-2.1.0.ebuild4
-rw-r--r--dev-python/flit/flit-3.2.0.ebuild48
4 files changed, 63 insertions, 2 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 98fa24ff4f58..b98e888eed18 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1 +1,2 @@
DIST flit-2.1.0.tar.gz 106459 BLAKE2B db51d8cc119ae8aa5f8d0ac1655cd29390065567391cbdf06ca7dbb98a79e96a6d8f318273c2f9a58aaf549090a903360701a844ac071d15304a21ea54052a91 SHA512 0fcbfaa1e5e83216a5c98cc87b0a8f2aa17e2c184ec3f09c7dd0dd5e695311be62344ac4f101cb71f87390513496f8c1152a2cd8d7363202f7696ee002f07a55
+DIST flit-3.2.0.tar.gz 115192 BLAKE2B dda4b9f5b56b9868d737516841d7fc49c0e97ef8a71f9f0628112f68c3dadae89a87aef56cebfe8ec3762af5970d206fe462add146d52b3893fb8852fd7f9625 SHA512 1db7c4118fe1d70d1e318db3bc282747d6cc3f3b626ad68420fa056e585caad9ff0a3f230e17c919ea260ddeb6330effc4bbed8b30d11ed7b27e78d9d7af0445
diff --git a/dev-python/flit/files/flit-3.2.0-tests.patch b/dev-python/flit/files/flit-3.2.0-tests.patch
new file mode 100644
index 000000000000..7a0a4c5c7a72
--- /dev/null
+++ b/dev-python/flit/files/flit-3.2.0-tests.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/test_config.py b/tests/test_config.py
+index 214cd17..815005b 100644
+--- a/tests/test_config.py
++++ b/tests/test_config.py
+@@ -5,6 +5,7 @@ from flit.config import read_flit_config, ConfigError
+
+ samples_dir = Path(__file__).parent / 'samples'
+
++@pytest.mark.skip("Needs internet access")
+ def test_invalid_classifier():
+ with pytest.raises(ConfigError):
+ read_flit_config(samples_dir / 'invalid_classifier.toml')
diff --git a/dev-python/flit/flit-2.1.0.ebuild b/dev-python/flit/flit-2.1.0.ebuild
index 2b61057002d7..4dd0cc171729 100644
--- a/dev-python/flit/flit-2.1.0.ebuild
+++ b/dev-python/flit/flit-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
+ <dev-python/flit_core-3.0.0[${PYTHON_USEDEP}]
dev-python/intreehooks[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/requests_download[${PYTHON_USEDEP}]
diff --git a/dev-python/flit/flit-3.2.0.ebuild b/dev-python/flit/flit-3.2.0.ebuild
new file mode 100644
index 000000000000..289ae9807716
--- /dev/null
+++ b/dev-python/flit/flit-3.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/flit_core-3.2.0[${PYTHON_USEDEP}]
+ dev-python/intreehooks[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ sys-apps/findutils
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/flit-3.2.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+
+python_prepare_all() {
+ printf -- "from setuptools import setup, find_packages\nsetup(name='%s',version='%s',%s)" \
+ "${PN}" "${PV}" "packages=find_packages(exclude=['tests'])" > setup.py || die
+
+ distutils-r1_python_prepare_all
+}