summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 07:04:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 07:31:50 +0200
commitc4b49937e7927e31ccfacd30a9c89a98561ec852 (patch)
tree2f151abd63c0410451a65e9587b6cf7c3f967eb4 /dev-python
parentdev-python/virtualenv-clone: Remove py3.10 from 0.5.5 (diff)
downloadgentoo-c4b49937e7927e31ccfacd30a9c89a98561ec852.tar.gz
gentoo-c4b49937e7927e31ccfacd30a9c89a98561ec852.tar.bz2
gentoo-c4b49937e7927e31ccfacd30a9c89a98561ec852.zip
dev-python/google-auth: Bump to 1.34.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.34.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index b75b3f7e50cc..3699e198cbe5 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -2,3 +2,4 @@ DIST google-auth-1.30.2.tar.gz 169368 BLAKE2B c01191313b4bd7ffdc62fbca20aeadcb01
DIST google-auth-1.32.1.tar.gz 171621 BLAKE2B e82f4666a38d3dbaa4aa4a4d5192afb711471432c0dcca44b1a1c52fa2171f1de0d7ffd8a7a6d5dc6dbc3a1dec16becabb26306a9ba3b3fd0998584dd1194cc6 SHA512 968c16c7fc5c8c589a94e24139c319ec7f2791b021d6240156d398d4795e6afee8e46591c4aa44457de6f98ca14e8edcb055fb3a02914b43ba5fab74a03d9fc6
DIST google-auth-1.33.0.tar.gz 178385 BLAKE2B 7d98afcd3a1dfc12a2af48297188c10f9618483ebdeeb8f7e02fca59d6255210a64b4917507a4525a3d6838198035fd827a1276da2a1f06169e83d1ca75fb485 SHA512 19da14b89cac28cf824f258d3dc662cbf40f4227e840594148c7ea3a6640dc00f06653c1b29846a9569d938a0fa307aff1c8425c015ab46d276485210eeb1227
DIST google-auth-1.33.1.tar.gz 178615 BLAKE2B 1600ca8861a7e75decfda5605414ff45d8f6d7ece40e0bb7a5892fe2289f1adc5bba313eab10c4d0e1f6e7a38634861e28518c2f02522ec924d6ed53805c4207 SHA512 c54356b21af5ddeda88023b886631050e8e4306ed444093ed6589d13d95af402f03928dc5b5f44f9b4c038128ed254aa14de6d852108f44949c42e2d05304062
+DIST google-auth-1.34.0.tar.gz 180860 BLAKE2B d536d689ff5b0c033f787228d643504d1888f0b73a9c6855fe4fae3af20772ef0640feca39c58c39f45681561dce6d5f3ec1d1f7d9699442fff0ec63fd019361 SHA512 7c3b64e8f85056fb660bbfd4f737053813a1e5b8aba52290882a0ddb9d9fd8c5365b767c78dd1e7859ef95caa6e653786d5a8747c8792bbee9c6fad1a5218910
diff --git a/dev-python/google-auth/google-auth-1.34.0.ebuild b/dev-python/google-auth/google-auth-1.34.0.ebuild
new file mode 100644
index 000000000000..2bb9e016a997
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.34.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}