summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-20 10:56:28 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-20 10:56:28 +0100
commitc54f344e00f2569d290c1fbbb89ed3400111cb85 (patch)
tree8463363299f1a6d7c9d5f4d8d0c726b89b3894fc /dev-python
parentdev-python/ipy: Replace distutils-r1 EXAMPLES use (diff)
downloadgentoo-c54f344e00f2569d290c1fbbb89ed3400111cb85.tar.gz
gentoo-c54f344e00f2569d290c1fbbb89ed3400111cb85.tar.bz2
gentoo-c54f344e00f2569d290c1fbbb89ed3400111cb85.zip
dev-python/jpype: Replace distutils-r1 EXAMPLES use
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild6
-rw-r--r--dev-python/jpype/jpype-0.6.3.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
index fda8e06d3cac..11d20268eeb9 100644
--- a/dev-python/jpype/jpype-0.6.2.ebuild
+++ b/dev-python/jpype/jpype-0.6.2.ebuild
@@ -26,6 +26,10 @@ PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
python_install() {
use doc && local DOCS=( doc/* )
- use examples && local EXAMPLES=( examples/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
distutils-r1_python_install
}
diff --git a/dev-python/jpype/jpype-0.6.3.ebuild b/dev-python/jpype/jpype-0.6.3.ebuild
index 82ec219eac24..f2ea32b2540f 100644
--- a/dev-python/jpype/jpype-0.6.3.ebuild
+++ b/dev-python/jpype/jpype-0.6.3.ebuild
@@ -26,6 +26,10 @@ DEPEND="
python_install() {
use doc && local DOCS=( doc/* )
- use examples && local EXAMPLES=( examples/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
distutils-r1_python_install
}