summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 20:48:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-05 16:10:57 +0200
commitc875fab70f1c60e1d16a7a449b8af339f28de94d (patch)
tree0f9a9a0d5c787e1e2a9319055be09bbf47fde99f /dev-python
parentsci-mathematics/arb: Switch to cmake.eclass (diff)
downloadgentoo-c875fab70f1c60e1d16a7a449b8af339f28de94d.tar.gz
gentoo-c875fab70f1c60e1d16a7a449b8af339f28de94d.tar.bz2
gentoo-c875fab70f1c60e1d16a7a449b8af339f28de94d.zip
dev-python/ssl-fetch: Tidyup and EAPI-7 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.4.ebuild15
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-9999.ebuild22
2 files changed, 8 insertions, 29 deletions
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
index 272b24e50d19..2d1ab1606377 100644
--- a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
@@ -1,31 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
-DESCRIPTION="A small convenience library for fetching files securely"
+DESCRIPTION="Small convenience library for fetching files securely"
HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
SRC_URI="https://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
-DEPEND=""
-
-RDEPEND="${DEPEND}
- >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
- "
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
pkg_postinst() {
- echo
elog "This is beta software."
elog "The APIs it installs should be considered unstable"
elog "and are subject to change in these early versions."
@@ -33,5 +25,4 @@ pkg_postinst() {
elog "Please file any enhancement requests, or bugs"
elog "at https://github.com/dol-sen/ssl-fetch/issues"
elog "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the Freenode network"
- echo
}
diff --git a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
index b19832d73841..97b36ef91545 100644
--- a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
@@ -1,40 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=no
-
-EGIT_BRANCH="master"
-
inherit distutils-r1 git-r3
-DESCRIPTION="A small convenience library for fetching files securely"
+DESCRIPTION="Small convenience library for fetching files securely"
HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
-SRC_URI=""
EGIT_REPO_URI="https://github.com/dol-sen/ssl-fetch.git"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
KEYWORDS=""
-DEPEND=""
-
-RDEPEND="${DEPEND}
- >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
- "
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
pkg_postinst() {
- echo
elog "This is experimental software."
elog "The APIs it installs should be considered unstable"
elog "and are subject to change."
- echo
+ elog
elog "Please file any enhancement requests, or bugs"
elog "at https://github.com/dol-sen/ssl-fetch/issues"
elog "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
- echo
}