summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2024-01-02 22:01:55 -0500
committerJoonas Niilola <juippis@gentoo.org>2024-02-15 15:29:45 +0200
commitc8b723e9a36a0249fe88df85f2e8e933047b360a (patch)
tree78f0788fbf5b6a09f8efc6a5a549353246acd8bf /dev-python
parentx11-libs/xapp: drop 2.4.3 (diff)
downloadgentoo-c8b723e9a36a0249fe88df85f2e8e933047b360a.tar.gz
gentoo-c8b723e9a36a0249fe88df85f2e8e933047b360a.tar.bz2
gentoo-c8b723e9a36a0249fe88df85f2e8e933047b360a.zip
dev-python/python3-xapp: Fix xapp python dependency Also disable py3.9
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python3-xapp/files/python3-xapp-configurable-python-target.patch31
-rw-r--r--dev-python/python3-xapp/python3-xapp-2.4.1-r1.ebuild (renamed from dev-python/python3-xapp/python3-xapp-2.4.1.ebuild)7
-rw-r--r--dev-python/python3-xapp/python3-xapp-2.4.1-r2.ebuild58
3 files changed, 92 insertions, 4 deletions
diff --git a/dev-python/python3-xapp/files/python3-xapp-configurable-python-target.patch b/dev-python/python3-xapp/files/python3-xapp-configurable-python-target.patch
new file mode 100644
index 000000000000..cdc6988934b9
--- /dev/null
+++ b/dev-python/python3-xapp/files/python3-xapp-configurable-python-target.patch
@@ -0,0 +1,31 @@
+From 70966ad200bf2a5e5769a2ac5f1d4da0a4a3aa51 Mon Sep 17 00:00:00 2001
+From: Sparky Bluefang <sparky@bluefang-logic.com>
+Date: Tue, 2 Jan 2024 22:19:46 -0500
+Subject: [PATCH] Make python installation configurable for distro packaging.
+
+---
+ meson.build | 2 +-
+ meson_options.txt | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+ create mode 100644 meson_options.txt
+
+diff --git a/meson.build b/meson.build
+index a9b67ca..a930803 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,7 +1,7 @@
+ project('python-xapp', version: '2.4.1', meson_version: '>=0.47.0')
+
+ pymod = import('python')
+-python3 = pymod.find_installation('python3')
++python3 = pymod.find_installation(get_option('python_target'))
+
+ subdir('xapp')
+
+diff --git a/meson_options.txt b/meson_options.txt
+new file mode 100644
+index 0000000..689a9c9
+--- /dev/null
++++ b/meson_options.txt
+@@ -0,0 +1 @@
++option('python_target', type: 'string', value: 'python3', description: 'Python installation to target')
diff --git a/dev-python/python3-xapp/python3-xapp-2.4.1.ebuild b/dev-python/python3-xapp/python3-xapp-2.4.1-r1.ebuild
index 6492fcd562ef..f10dee3075c2 100644
--- a/dev-python/python3-xapp/python3-xapp-2.4.1.ebuild
+++ b/dev-python/python3-xapp/python3-xapp-2.4.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit meson python-r1
@@ -14,11 +14,10 @@ SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
- >=x11-libs/xapp-2.4.1[introspection]
+ <x11-libs/xapp-2.8.0[introspection]
"
RDEPEND="
${DEPEND}
diff --git a/dev-python/python3-xapp/python3-xapp-2.4.1-r2.ebuild b/dev-python/python3-xapp/python3-xapp-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..b031ce2f5d94
--- /dev/null
+++ b/dev-python/python3-xapp/python3-xapp-2.4.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapp"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ >=x11-libs/xapp-2.8.1[introspection,${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # Make python installation configurable for distro packaging
+ # https://github.com/linuxmint/python3-xapp/pull/23
+ "${FILESDIR}"/${PN}-configurable-python-target.patch
+)
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython_target="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}