summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-06 18:38:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-06 19:04:18 +0200
commitc8e652d790278984d9415c1c6ed1a8b554587554 (patch)
tree742f8ec524b8f8e8b4346bcf8bcf363d554d90d8 /dev-python
parentdev-python/chameleon: Bump to 3.10.0 (diff)
downloadgentoo-c8e652d790278984d9415c1c6ed1a8b554587554.tar.gz
gentoo-c8e652d790278984d9415c1c6ed1a8b554587554.tar.bz2
gentoo-c8e652d790278984d9415c1c6ed1a8b554587554.zip
dev-python/eradicate: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/eradicate/Manifest1
-rw-r--r--dev-python/eradicate/eradicate-2.1.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/eradicate/Manifest b/dev-python/eradicate/Manifest
index b5574785b132..83c173a3975f 100644
--- a/dev-python/eradicate/Manifest
+++ b/dev-python/eradicate/Manifest
@@ -1 +1,2 @@
DIST eradicate-2.0.0.tar.gz 8390 BLAKE2B 22dced2414622138655be80d1c10b746519d313959c7620cb54c4dc27247b0c29b7607c54934fe1dc379bec2cb729213b7ffb1d27f3f7f9b9a9d186aa9402674 SHA512 947a3890ccb1dbb52e73b37e632ae5ba1eff732d9d0b0dc127fa8dc908412e864fcda3203274d5eb1645b22f6e97a90ebb13cd4363a2360d6591475d909bdb96
+DIST eradicate-2.1.0.tar.gz 8706 BLAKE2B 5b5cab1c465c8295157bec1e8e39f0e33dbe31957da01ec44bbabf54a2b19c519a35cd7d2b92217d5395ce7397b3ae70175766a83b66d05e723fc5b5a019eb40 SHA512 a9b06745bceff909a1bbe34348b8e4c17d7f1e0ab3b554206633f350725c34a9b7238b3af6a40516081bc06aa86cdd593b27b90efa083ac024b0226f7cfc4df3
diff --git a/dev-python/eradicate/eradicate-2.1.0.ebuild b/dev-python/eradicate/eradicate-2.1.0.ebuild
new file mode 100644
index 000000000000..3d56e702338b
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest