summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 09:31:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 11:09:47 +0100
commitc991b11500c87b37be6e01b90e5c9e71f0128423 (patch)
tree052f631fb44461f107bede09629aff557a16c8e0 /dev-python
parentdev-python/pyopenssl: Bump to 20.0.1 (diff)
downloadgentoo-c991b11500c87b37be6e01b90e5c9e71f0128423.tar.gz
gentoo-c991b11500c87b37be6e01b90e5c9e71f0128423.tar.bz2
gentoo-c991b11500c87b37be6e01b90e5c9e71f0128423.zip
dev-python/pytest-mock: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index c44588580b2d..aecb5ef21a58 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1 +1,2 @@
DIST pytest-mock-3.3.1.tar.gz 27551 BLAKE2B 9e3602b988c0e27caa295d42d7400cbe7e3e30392511e662fa6ec16ec9fa4ef776d3e64b63b0345d1b520f753c6776103f507f91f0bad022544bfccc510b7e6b SHA512 ffd53974f82f725cf3bdbe750c1deb568ad1a12a67532eca93ff28d80b1cbcd8ebf709985f5473717c9d54345b251c1627c0567821e9e8b9e102db5c16cf7421
+DIST pytest-mock-3.4.0.tar.gz 28115 BLAKE2B 0a7f9098955d57f7121c04f7ab706dd67eb52d8ec0b2254552460eb90b2e3fef3cd3b925cf46619532ffe7bede2f208bf822e465647f3ac4504566c18ff58a75 SHA512 5456b60bdd06a63859232b28aeb79be643e8298e69ae103cb6e194891987e01b17771ad895dfead97fa45531959689fb202bb1ebc9ba44491098760c10d1ef43
diff --git a/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild
new file mode 100644
index 000000000000..dc04d9251c5b
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
+}