summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-23 08:04:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-23 09:27:25 +0200
commitc9feff866f9d828dcd2c11b51934e308fb234c0e (patch)
treeb625502798ddc20f94e3ca0ad8d4d4d160849b98 /dev-python
parentdev-python/identify: Bump to 2.3.1 (diff)
downloadgentoo-c9feff866f9d828dcd2c11b51934e308fb234c0e.tar.gz
gentoo-c9feff866f9d828dcd2c11b51934e308fb234c0e.tar.bz2
gentoo-c9feff866f9d828dcd2c11b51934e308fb234c0e.zip
dev-python/zeroconf: Bump to 0.36.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.36.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index f71fae7243b0..f6266e8fcb63 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -4,3 +4,4 @@ DIST python-zeroconf-0.36.5.gh.tar.gz 129395 BLAKE2B 3e62da5f38bd0648ed300c2ecea
DIST python-zeroconf-0.36.6.gh.tar.gz 129469 BLAKE2B f52348d8fb5a2ed865bc946ad52ea0df474fd59ca5735411381366f08b2a5e1b673916256871128cc9f3a7fef1e72e2ea35fc113e5e41fe63f67659b3cc8f0ba SHA512 fe8d9026e9a19d267c7e734df51253bf69d5ca38b79b00b752886d59288073e8a4b9de40bbd2324064a574f40bec147c8b44d4f3395e480794600c440f2d7c9c
DIST python-zeroconf-0.36.7.gh.tar.gz 129775 BLAKE2B 9b8ea59e2e62de4476c6b014b925b000b3c47cd9f965a23dd1c6a15b3a4f1ac7a4473eb6b9953d8893a445ffefcd1167c1e32b87b210ed3777fb046b3bd584f4 SHA512 c589c58c92d649c42f9a752d080c2b36a1fcc0c892ab6868cc79a3727087dd95f3e7b779ffd8b040d649453b8c70de4214d76d0f6c16c46a67628545c2472a54
DIST python-zeroconf-0.36.8.gh.tar.gz 129890 BLAKE2B dafd1a660e611afcac0367b6f4618dd488161d30337fa1d8bd7f43af06446785e86125ae50781b341549fb9b1c70070e6b86ba271a98e5544f5d0e3287640e00 SHA512 928a78a59a5e23182c5f0af8cc8bda477b8225ffaf50e25bdd746ce7b40f7e215e5f23d7a4a282f802c9a4b7b53cbc60c38f547f382b8eff5eb14d1a21f108c1
+DIST python-zeroconf-0.36.9.gh.tar.gz 130154 BLAKE2B d9a96a853a12d3f9f0e4fd9f80bb7114ce25b2fed730ed79baa4ac07a6108a6f5cfc56232ba77f829a947e2961a91c3e1eed224fadf95b2e433ebe0c7b9374ee SHA512 27558fdb9dd8539fffdc5756d180dce921bed010fb7eb2e11254e162792ba663fcaa74afbfcebfb86b5c6aa9187d00a302f6a402cf40986f0bc9e3bed1dd0e19
diff --git a/dev-python/zeroconf/zeroconf-0.36.9.ebuild b/dev-python/zeroconf/zeroconf-0.36.9.ebuild
new file mode 100644
index 000000000000..b416d399c1d2
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.36.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)