summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-17 23:54:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-18 00:17:10 +0100
commitca268347d1e6087c447b51d150a1adfa7d1e8b2d (patch)
treed496806888f06f9508acfc5747f2116feca5613e /dev-python
parentnet-misc/electrum: Bump to 4.0.8 (diff)
downloadgentoo-ca268347d1e6087c447b51d150a1adfa7d1e8b2d.tar.gz
gentoo-ca268347d1e6087c447b51d150a1adfa7d1e8b2d.tar.bz2
gentoo-ca268347d1e6087c447b51d150a1adfa7d1e8b2d.zip
dev-python/botocore: Bump to 1.19.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.39.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 137d4c419522..c76a354d76cc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.19.30.tar.gz 7224700 BLAKE2B 50712be7e6e4a8a22607d567a8d227bbc6d
DIST botocore-1.19.36.tar.gz 7291325 BLAKE2B d1f79298a0f47d704418cac8390a5d500b1f300fc9bdbc0b215a3630adb70c29a951c6dff2a6ebfde42872cbc3af4c442d09fa0233b2c957521e6a5e05816c60 SHA512 420ad7c59496b2b74ba6ecde8dc40ac3e47c5676335f7471448fcdde5b70bda3bd7516963788d8a7a940aaa9cf488b6529e6fbd2842806f58520cd8e2dc15a60
DIST botocore-1.19.37.tar.gz 7335789 BLAKE2B 3df00ad1f0d34f8f8408741b503fafdf9bdaacd9f5b0c52ffbc0b3172e7b0d01e741a076430268c55c39f1fe050a9b8bcc2d183eb54830886c7f3f050a22c408 SHA512 53ff17dcba3e72910709de7fe4504a04a507a708c2674039cfb682276ea7f8f46d3afeadbb41103d02141183d6216aab5964b0df98033cd12946ed1c83373aaf
DIST botocore-1.19.38.tar.gz 7358201 BLAKE2B 16dee2bd0d27996fd761b19918c36de0475c827cb27d0c1505e438436872337f0a5b0ddceb3c4ffb3b5c15592a2aa328f8eec94e2e6ab55aa705299ea847c465 SHA512 51a6c7a0ab950c4a7f0d7859d90c39f30f4be2789b55f520f5318a00878c62a2f5eaa9741e53953d3226a23137415fc4318ca09d37d690e71b8f2078b2662cfe
+DIST botocore-1.19.39.tar.gz 7371273 BLAKE2B 574b0dedfbae40d496d5600ca37ec1181e74d48301deacaeca8b1628df1d5bdb3dfcdd0310b3e4860c9f0605cca176dadb4e313040a27521a0c0643ac7d0df0f SHA512 4b8b197a222f70cb136aeeac04178a27c229a2e7a82e42c66ab5f7366039a3d1748290d59df14db9039016247782c8f144757890e9fa0ebef4ea61f81931600f
diff --git a/dev-python/botocore/botocore-1.19.39.ebuild b/dev-python/botocore/botocore-1.19.39.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.39.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}