summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-15 20:48:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 22:55:50 +0300
commitca2d9d0f406f7c925e1c50a674ef3729a9ede5aa (patch)
treea6a3d184a206d06fff73e3f6b9d6f1677e223e9a /dev-python
parentdev-python/zope-schema: add 6.2.1 (diff)
downloadgentoo-ca2d9d0f406f7c925e1c50a674ef3729a9ede5aa.tar.gz
gentoo-ca2d9d0f406f7c925e1c50a674ef3729a9ede5aa.tar.bz2
gentoo-ca2d9d0f406f7c925e1c50a674ef3729a9ede5aa.zip
dev-python/immutables: add 0.19
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/immutables/Manifest1
-rw-r--r--dev-python/immutables/immutables-0.19.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 10d2356afba6..b4ac2fa1f35f 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1 +1,2 @@
DIST immutables-0.18.gh.tar.gz 84891 BLAKE2B 2e800e1b7b354781ef221315b80877e57ef446753c4a42e411196379e2bc921f71918c5ecd5cc693ca54cb7c401bef31161e9d249407b705626fe95d0e4e9fcc SHA512 1477ff6d9a6c02c3619b209352096abefb913cf53d392748e0940160067ecdcf2b89ad9ce807161ededaa5062105a2e5c5a3303bd02752a5f07b5f68f1c1044c
+DIST immutables-0.19.gh.tar.gz 85695 BLAKE2B b6457bd4e61c79ffc4ae83c1be3845ea1914ef6604ee8b0886c1ab24dba96e226444af5adc1032dc36e6f3058acac8a8f0289ce97f97874b02aae85eb3bc2ee1 SHA512 b1027e9ab4a304dcb953037a1ea4af082d0524255bcf3f3f368deda85b9a9e5b1c556638aab7a10cbf200fc14b85c8b739f212035f8ead1dff941b8f6da09668
diff --git a/dev-python/immutables/immutables-0.19.ebuild b/dev-python/immutables/immutables-0.19.ebuild
new file mode 100644
index 000000000000..e0907ac8cb89
--- /dev/null
+++ b/dev-python/immutables/immutables-0.19.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="
+ https://github.com/MagicStack/immutables/
+ https://pypi.org/project/immutables/
+"
+SRC_URI="
+ https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/mypy/d' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_mypy.py
+ )
+
+ rm -r immutables || die
+ distutils-r1_src_test
+}