summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-11-30 12:19:36 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-12-06 23:12:42 +0100
commitcad23e14efe69f47cc434b125d152114cd50ead5 (patch)
treee24c54f1b1b6d963d76b5a60e0f162f4be0cd838 /dev-python
parentmedia-gfx/digikam: Fix cleanup_digikamdb, DB w/ >=mariadb-10.2 (diff)
downloadgentoo-cad23e14efe69f47cc434b125d152114cd50ead5.tar.gz
gentoo-cad23e14efe69f47cc434b125d152114cd50ead5.tar.bz2
gentoo-cad23e14efe69f47cc434b125d152114cd50ead5.zip
dev-python/construct: version bump to 2.8.16.
Closes: https://github.com/gentoo/gentoo/pull/6353 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/construct/Manifest3
-rw-r--r--dev-python/construct/construct-2.8.16.ebuild33
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index bb71c86c98b4..dbbf6584d5f8 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,3 +1,4 @@
DIST construct-2.5.2.tar.gz 58373 SHA256 665b6271eeadf15219c726b180c8d7a641d026784d72ca3dad90a20aae009020 SHA512 dbfa28f58821811fa28ef170818d74212e76389a017c4073acd24025ace292285828506cb44387ff07c1c05ae70766a3a0679baea25deb3b0dcc31c85b24340b WHIRLPOOL ebe5ac0a09e317a2d8c123f24c110b3ea303c179710da6112c8f376bbf1d526c4c29ebf7f60c12f8873f74ec4ebabf010b4e537173fe28f166da6f49b79635cc
DIST construct-2.8.12.tar.gz 720277 SHA256 67ee2c69a11bdadc0705c7e0de0ff16ef74b730932537e22ac1f64f479240ffa SHA512 4d0f59623a62eeab3c10e95b4e8153a1593219bcbcbbe5f87e75ba0a010b62021a9502faf715623faa78b4e397f1a74b41e9bffd1ede92dbebf87b0d4a59b66b WHIRLPOOL a73a2ad27c32e0ec59eb2b04fb45eb9f16e93460f722c3d19007840e141dd846695659adff3f6d50581fbf4ecaa37b982317722fda847bf3eb298432146ec19d
-DIST construct-2.8.14.tar.gz 719633 SHA256 7ca89f47a6e3e702465aa360ac3a2c578728cbd7b6c82659ab2f7f48aae4f0e3 SHA512 ada1853ff9559f19dbb153ef4b60a6daf58dadaf0524fcb35c4a38e8c0a476acfbeec2f4d02ebfa1858c9d2660ffc8695d7ff8055a23e8dc40aca8290c53ac69 WHIRLPOOL 9feb7940e160949ed5ce3db246297c5b563f2a10bce7f79866ae6bcc2b18728201aacca76592e5806e08f724217e32026c1bcfcac74df862f96e68fde571c0ad
+DIST construct-2.8.14.tar.gz 719633 BLAKE2B cba727069463277cb6340571745d9dc896eb4b47090e66000233bf61b9d47ccb07300c0c9a38d0fc6bda14d810d3b68cc6bf67d8032fc33015496ba37f370c31 SHA512 ada1853ff9559f19dbb153ef4b60a6daf58dadaf0524fcb35c4a38e8c0a476acfbeec2f4d02ebfa1858c9d2660ffc8695d7ff8055a23e8dc40aca8290c53ac69
+DIST construct-2.8.16.tar.gz 719786 BLAKE2B 44d90014136612080f4a97fa32845b7610bb2378ecf0ba81b105e265874c3d05c18a70f98a6cba1eaec69b5b68887b0611b7aadd4188c196c99fd15c2b0ca294 SHA512 6128da944b323b58f79a9b386fd9dba65fdcc31ce8da2b6cafebfe2f126031dd77ffcfe4885020b6122304acf0b0f87792ddf79669517b21ac1f49952c2c46ee
diff --git a/dev-python/construct/construct-2.8.16.ebuild b/dev-python/construct/construct-2.8.16.ebuild
new file mode 100644
index 000000000000..ceeedd6f36d5
--- /dev/null
+++ b/dev-python/construct/construct-2.8.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ ewarn "Version 2.8.x has significant API and implementation changes from"
+ ewarn "previous 2.5.x releases. Please read the documentation at"
+ ewarn "http://construct.readthedocs.io/ for more info."
+}