summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-12-09 21:58:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:44:16 +0200
commitcbf77ceb7c455db7ba634ed215b4b615ec6505e5 (patch)
tree8988f804704583bcc2f695e4c2496df6a78e11c2 /dev-python
parentmedia-gfx/zbar: arm64 keyworded (bug #759160) (diff)
downloadgentoo-cbf77ceb7c455db7ba634ed215b4b615ec6505e5.tar.gz
gentoo-cbf77ceb7c455db7ba634ed215b4b615ec6505e5.tar.bz2
gentoo-cbf77ceb7c455db7ba634ed215b4b615ec6505e5.zip
dev-python/pipenv: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2020.8.13.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index a5728565415c..f8d9b27c9b40 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,2 +1 @@
DIST pipenv-2020.11.4.tar.gz 11574683 BLAKE2B cb2ac4ba6b07377a3a5540b23756afac38a02691e495ba93031815417d001701b919221fd83d0f9e6b94d4f28c1fa754c2c31e289830305a8c8ac75d847209c4 SHA512 c9015eb9a449fa517f31619d1fec5d99882da915a50e189ba6ab9c7c147862f9734f0df200330d666380afe5d2cf52d18015c539635ca6459042ab50d3ccd059
-DIST pipenv-2020.8.13.tar.gz 11573493 BLAKE2B ac6c6f0336f0c675f73fbecfdefe158eb2a53b5aa4559850b3c9a050404d9d18b0ff2ca3cb62031da027937244a6bbb0d4c1ec433073e429518ec0ea908cb12e SHA512 90ccaf386bc68d856ee9c645084cb65c4213902a8c87e2059cc2274b88d922c3b02c58c15d05945e1f61e8b816ef92a11672cadaf125143bd5019ab25ff0b19e
diff --git a/dev-python/pipenv/pipenv-2020.8.13.ebuild b/dev-python/pipenv/pipenv-2020.8.13.ebuild
deleted file mode 100644
index d9f0436d554f..000000000000
--- a/dev-python/pipenv/pipenv-2020.8.13.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
-
-inherit distutils-r1
-
-MY_PV=${PV/_beta/b}
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pip-18.0[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
- "
-
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- <dev-python/pytest-5[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- # remove vendored version of PyYAML that is backported to Python2
- # this should be removed when upstream removes support for Python2
- rm -vR "${S}/${PN}/patched/yaml2/" || die
- # disable running of unittests in parallel with xdist
- sed -i 's/addopts = -ra -n auto/;&/g' setup.cfg
- sed -i 's/plugins = xdist/;&/g' setup.cfg
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
-}