summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-14 04:36:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-14 04:53:24 +0100
commitcc7557a0aad403eb00784fe916121d5dc8639eb0 (patch)
tree10eb2ac605641b4656db06d4af17ba9a597abb80 /dev-python
parentdev-python/hypothesis: Remove redundant version (diff)
downloadgentoo-cc7557a0aad403eb00784fe916121d5dc8639eb0.tar.gz
gentoo-cc7557a0aad403eb00784fe916121d5dc8639eb0.tar.bz2
gentoo-cc7557a0aad403eb00784fe916121d5dc8639eb0.zip
dev-python/hypothesis: Bump to 5.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.1.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 95a9dd19cb0c..1e90e764edd0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda976
DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b82ce2f9b42e7391beae8f67debdf50494e662f07bf109274d4e29fcf3a1c1c944597cde2a4ff9e7ca65a48f1244c3205f365af SHA512 91d7d2cda32fd40d5368fdd1e60b990b8307573782d822113b6817a5c0b670610693a2f2b013f828913549946fa3dc15f45303bf7d3226bdc1e4527bc18981fb
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
DIST hypothesis-python-5.1.4.tar.gz 8989696 BLAKE2B 9d85cb1473654e36a235a07d2390fc967d6d7f2944e5294dedbca15ddb3c49901b04e9277ee80ff7591aa2b81ea0e2d537051f96b685900aefab5db70d135ac6 SHA512 25d0112f7b7a13221b8b68d553f4085344f1e8681c8795fac0bcfd714400a828539298d2919d3e638979eadd5daa65ef7ee8b0b946df076145e59c8bb7058a64
+DIST hypothesis-python-5.1.5.tar.gz 8989752 BLAKE2B e1dc2720fd8500436ff0ec0fadd8c7986f279be125f8cebf376349d6c6d1d28f9225cceb2fa54ab66e92c6750832dc6d157cf156980e7f58aa7251a1eff625fd SHA512 89edc57116b3c503df2f0c6d4e60637ace6a7fc5c4ece6b426362b01a0be11e79be1e95784e24d849ac120000165ff46efd78c6cb6b163aebcb2b5a8c8d4c8e1
diff --git a/dev-python/hypothesis/hypothesis-5.1.5.ebuild b/dev-python/hypothesis/hypothesis-5.1.5.ebuild
new file mode 100644
index 000000000000..24078c547ce7
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.1.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}