summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-05-15 22:28:35 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-05-18 23:21:06 +0200
commitccc0272b4aad32a0513aaaed7a2ddd3171815afd (patch)
tree45b5001812a5b0d6ac7ca089e04984afde62c1c1 /dev-python
parentkde-misc/kshutdown: Drop 4.99_beta (diff)
downloadgentoo-ccc0272b4aad32a0513aaaed7a2ddd3171815afd.tar.gz
gentoo-ccc0272b4aad32a0513aaaed7a2ddd3171815afd.tar.bz2
gentoo-ccc0272b4aad32a0513aaaed7a2ddd3171815afd.zip
dev-python/brython: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.7.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 44fbf3095b8b..cade0ebe8d22 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,3 +1,4 @@
DIST brython-3.6.0.tar.gz 9310837 BLAKE2B 616874f2a9c303e910a3fd2910aad6ffe360f87e98d009d66e85fd8c05d61c5d96c1a313214c08b69b5d073a23008b23d882a607af0d54f7d2942fcd2b6861ff SHA512 c59cee89634a2439a6fc64d3397966762aa508c6c00d05186138acce25fcf6597230511e30a261217898bca3d86a11eea92516cfe630c5d82cb271603dbecb2c
DIST brython-3.6.2.tar.gz 9314999 BLAKE2B 809b9367eb42e723aa58dc22f1d1186144258135bf129de6d28be9a3d86f5f039c2c566e897ed6e8b436ee1ddd80ea2950c6053e366e204255877a777bfe68db SHA512 3edc603bb06a3ce5a383f6e86023e3266cf3ccc916c209fcef0ee69b4cb5445aba820034b5ce33b7c828c5a9a50f48c1226bcb69724967ec438c0702558c7641
DIST brython-3.7.0.tar.gz 10334976 BLAKE2B cbbd3b77c1ef4cb5459621e33456ea7e1999428c0aaf2e52f60f4c1a3c737c84649880dc7e06d9f5b19fd4a172982ee3c1bd8df4f2e264818d6e5cac0908bdb1 SHA512 38f42c5c4399317c9a75af3159776d15047d6c09fd89b3f4d244f9077684cdcb3aec2a33304b6fe0005c129291b2b1ecfb0274f766da6005c0ff215751660df0
+DIST brython-3.7.1.tar.gz 9898874 BLAKE2B 2fbdfae401662878138c5315fc821de77125476d1567dcc395b018891282ca3880ec63e377d9ab8381060e54b6d4947f036f75a518ef363b2549d29a12eace78 SHA512 0ab073cd12ae5f2c45a205b37d20d68a996d6ba7247e8a3b8e461158147070294bebba46368c6618771b6bcac11d5a253d63be02cbab1241c11d74ae56d0fd17
diff --git a/dev-python/brython/brython-3.7.1.ebuild b/dev-python/brython/brython-3.7.1.ebuild
new file mode 100644
index 000000000000..447c9b9ba91f
--- /dev/null
+++ b/dev-python/brython/brython-3.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}