summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-15 09:22:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-15 09:27:05 +0200
commitcdf636ffdc1530deb5a5246e30da217273fec166 (patch)
tree6224e9ae952f92ab31b917471880e35908b4eea2 /dev-python
parentdev-libs/zlog: Add v1.2.14 (diff)
downloadgentoo-cdf636ffdc1530deb5a5246e30da217273fec166.tar.gz
gentoo-cdf636ffdc1530deb5a5246e30da217273fec166.tar.bz2
gentoo-cdf636ffdc1530deb5a5246e30da217273fec166.zip
dev-python/httpretty: Remove redis tests
The redis tests causes a dependency on dev-python/redis-py but it is skipped anyway due to requiring a running redis server. Closes: https://bugs.gentoo.org/722724 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/httpretty/httpretty-1.0.2-r1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
index eb33b6f3b1d3..e2bb7e42bf11 100644
--- a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
+++ b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
@@ -37,6 +37,9 @@ python_prepare_all() {
sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
# tests requiring network access
rm tests/functional/test_passthrough.py || die
+ # requires running redis server
+ # it is skipped correctly but it causes unnecessary dep on redis-py
+ rm tests/functional/bugfixes/test_redis.py || die
distutils-r1_python_prepare_all
}