summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-05-20 09:03:54 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-05-20 09:03:54 +0200
commitd0bd0c9d122ec146e96d04a766b32c2c9f4bdd4e (patch)
treee32506d88c838dcea70f2cd58ce67f715275de26 /dev-python
parentmedia-sound/ncmpcpp: Stable for HPPA PPC64 (bug #583502). (diff)
downloadgentoo-d0bd0c9d122ec146e96d04a766b32c2c9f4bdd4e.tar.gz
gentoo-d0bd0c9d122ec146e96d04a766b32c2c9f4bdd4e.tar.bz2
gentoo-d0bd0c9d122ec146e96d04a766b32c2c9f4bdd4e.zip
dev-python/entrypoints: New ebuild, required for nbconvert
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/entrypoints/Manifest1
-rw-r--r--dev-python/entrypoints/entrypoints-0.2.1.ebuild60
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch8
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch20
-rw-r--r--dev-python/entrypoints/metadata.xml21
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/entrypoints/Manifest b/dev-python/entrypoints/Manifest
new file mode 100644
index 000000000000..8ba52629a387
--- /dev/null
+++ b/dev-python/entrypoints/Manifest
@@ -0,0 +1 @@
+DIST entrypoints-0.2.1.tar.gz 11126 SHA256 0d6b6798446c2e5e5dd6691e79356c29e82234bdb67995233f57413a11f2ded4 SHA512 67a24fc53ae8bdac6bda163d2c8057b158979d55ccdbcdb8709966573bf0a999728e04eb92a05fbc2c0d532593de0ec6518bcfed1d5bcf875b00bbd5c48494c7 WHIRLPOOL f673fb42bad930bb1907692013df469d64b9afb77c3e0acca250fb0b14fe17ec3962cb60de2f0760ede40c8f039690851424b816e047669916ff1d73389daaf7
diff --git a/dev-python/entrypoints/entrypoints-0.2.1.ebuild b/dev-python/entrypoints/entrypoints-0.2.1.ebuild
new file mode 100644
index 000000000000..c67fb71b9dda
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7)
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}"-setup.py.patch
+ "${FILESDIR}/${P}"-init.py.patch
+)
+
+python_prepare_all() {
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+
+ mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+ }
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch
new file mode 100644
index 000000000000..40d5d82730d3
--- /dev/null
+++ b/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch
@@ -0,0 +1,8 @@
+__init__.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/entrypoints/__init__.py
+@@ -0,0 +1 @@
++from .entrypoints import *
+\ No newline at end of file
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch
new file mode 100644
index 000000000000..98786854773c
--- /dev/null
+++ b/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch
@@ -0,0 +1,20 @@
+setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,13 @@
++from distutils.core import setup
++
++setup(name='entrypoints',
++ version='0.2.1',
++ description='Discover and load entry points from installed packages.',
++ author='Thomas Kluyver',
++ author_email='thomas@kluyver.me.uk',
++ url='https://github.com/takluyver/entrypoints',
++ packages=['entrypoints'],
++ classifiers=[
++ 'License :: OSI Approved :: MIT License'
++ ]
++)
+\ No newline at end of file
diff --git a/dev-python/entrypoints/metadata.xml b/dev-python/entrypoints/metadata.xml
new file mode 100644
index 000000000000..acbfe4f76fbe
--- /dev/null
+++ b/dev-python/entrypoints/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Entry points are a way for Python packages to advertise objects with
+ some common interface. The most common examples are console_scripts
+ entry points, which define shell commands by identifying a Python
+ function to run.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">takluyver/testpath</remote-id>
+ </upstream>
+</pkgmetadata>