summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 19:05:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 19:32:56 +0100
commitd1301b2b61befeb46de7474a426c176b43125f5a (patch)
tree822bab60048a7ff4b47311af3a596e91fb18abbd /dev-python
parentdev-python/python-neutronclient: Bump to 11.2.0 (diff)
downloadgentoo-d1301b2b61befeb46de7474a426c176b43125f5a.tar.gz
gentoo-d1301b2b61befeb46de7474a426c176b43125f5a.tar.bz2
gentoo-d1301b2b61befeb46de7474a426c176b43125f5a.zip
dev-python/croniter: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-2.0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index 6f3cd15d196f..30849936e5cb 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1 +1,2 @@
DIST croniter-2.0.1.tar.gz 42599 BLAKE2B 78bc432fe14995d33bd2b0290772849c825fd11e976913b7e68d9c7490e7d768df7c0ced614b0246d17681aea351232529eac3316a7f117bf0179fa2879ad1d5 SHA512 548738d60af7628e986e4f5252025c031154c3a6885d06e1429255a4f2105d56d6e68793ae8a9a0aff8325792524b49665083ddfdbc3df8efa3109b052a043a4
+DIST croniter-2.0.2.tar.gz 42739 BLAKE2B 3156c6676e38aead9efd425d92676620e6736bbccef7b4e53ca1ab91728f522e4aa9ac4b518205717e6bc7034dd231f90d6f6f5bc58d04da0c8f76ce8cbc1ff6 SHA512 f1ef58b21be070a4da7447322130bb2a7672572a78c0214d6df37428a8103234582c647747e76d890194dde8293dd2cc097a65484738a03423061545263417fe
diff --git a/dev-python/croniter/croniter-2.0.2.ebuild b/dev-python/croniter/croniter-2.0.2.ebuild
new file mode 100644
index 000000000000..3d5f6c8e5f9f
--- /dev/null
+++ b/dev-python/croniter/croniter-2.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="
+ https://github.com/kiorky/croniter/
+ https://pypi.org/project/croniter/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest