summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-06-26 01:47:25 +0200
committerSebastian Pipping <sping@gentoo.org>2021-06-26 01:57:53 +0200
commitd4beda25f7a27938194241dfaaef1ffafb12c8ce (patch)
tree6a0e4d8dc0faaa61ba3df1e61707f640e4bedb02 /dev-python
parentsys-fs/squashfs-tools-ng: Drop old versions (diff)
downloadgentoo-d4beda25f7a27938194241dfaaef1ffafb12c8ce.tar.gz
gentoo-d4beda25f7a27938194241dfaaef1ffafb12c8ce.tar.bz2
gentoo-d4beda25f7a27938194241dfaaef1ffafb12c8ce.zip
dev-python/python-dotenv: Address collision with dev-ruby/dotenv
I'm using a second entrypoint here rather than a plain rename to not break (1) the tests and (2) access to argv[0] by python-exec. Closes: https://bugs.gentoo.org/798648 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.19, Repoman-3.0.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-dotenv/files/python-dotenv-0.18.0-second-entrypoint.patch24
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.17.1.ebuild1
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.18.0-r1.ebuild38
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.18.0.ebuild1
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/files/python-dotenv-0.18.0-second-entrypoint.patch b/dev-python/python-dotenv/files/python-dotenv-0.18.0-second-entrypoint.patch
new file mode 100644
index 000000000000..9d69c8b6b008
--- /dev/null
+++ b/dev-python/python-dotenv/files/python-dotenv-0.18.0-second-entrypoint.patch
@@ -0,0 +1,24 @@
+From c57f0aa05145ff84b708ffd64106ae741096027e Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 26 Jun 2021 01:38:14 +0200
+Subject: [PATCH] setup.py: Add second entrypoint "python-dotenv"
+
+---
+ setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.py b/setup.py
+index fd5785a..bb31c40 100644
+--- a/setup.py
++++ b/setup.py
+@@ -42,6 +42,7 @@ setup(
+ entry_points='''
+ [console_scripts]
+ dotenv=dotenv.cli:cli
++ python-dotenv=dotenv.cli:cli
+ ''',
+ license='BSD-3-Clause',
+ classifiers=[
+--
+2.31.1
+
diff --git a/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
index 037518dc4898..eabf304977ad 100644
--- a/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
@@ -23,6 +23,7 @@ DEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/sh-1.09[${PYTHON_USEDEP}]
)"
+RDEPEND="!dev-ruby/dotenv" # bug 798648
DOCS=( CHANGELOG.md README.md )
diff --git a/dev-python/python-dotenv/python-dotenv-0.18.0-r1.ebuild b/dev-python/python-dotenv/python-dotenv-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..aa3667814def
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.18.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.18.0-second-entrypoint.patch # bug 798648
+)
+
+distutils_enable_tests --install pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ # Avoid collision with dev-ruby/dotenv (bug #798648)
+ rm "${D}"/usr/bin/dotenv || die
+}
diff --git a/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
index 3fd9aa665e52..e412eed05fb6 100644
--- a/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
@@ -21,6 +21,7 @@ DEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/sh-1.09[${PYTHON_USEDEP}]
)"
+RDEPEND="!dev-ruby/dotenv" # bug 798648
DOCS=( CHANGELOG.md README.md )