summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-27 07:31:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-27 07:37:48 +0200
commitd4fe51db479119fd604253d72abfb070cd697532 (patch)
treec19177b8fc0eea5a2c3f9ca0c96b7b6ad11f28a9 /dev-python
parentdev-python/networkx: Bump to 2.6.2 (diff)
downloadgentoo-d4fe51db479119fd604253d72abfb070cd697532.tar.gz
gentoo-d4fe51db479119fd604253d72abfb070cd697532.tar.bz2
gentoo-d4fe51db479119fd604253d72abfb070cd697532.zip
dev-python/path-py: Bump to 16.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-16.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 6d9cfca27f91..a500521b455a 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,2 +1,3 @@
DIST path-16.0.0.tar.gz 44187 BLAKE2B 839c8a9d10cf4ac3f738a9e661fbfb1059554f965fc8224457c05c249578a18118129b69b46276fe569fc8bc33b398be1462d660bb20b905ecc6ab2b4db3f8fc SHA512 3874321d488543219a081adcb692739fcc4935cddaf563b58fe5a97c2cee4b5b683b2be52d220854b2f2224d15ec2bde054a53862352c249f14f1460a72d5e72
DIST path-16.1.0.tar.gz 45551 BLAKE2B bb22684f9b8d1996d8dec5bfc3d6b116595338a6d9f55f3c6084e0c6a41d6a708174ddd6fbcfa29e37f042f65e85465f4155f71569a1851994f03ddd4e4eaad7 SHA512 85d2d0415e28eb737f9fb6eaf669b687af768c5a1c4cf20a3c36706209fe6a97b44c34ff07468d8fefae372049e18d277e245f080dc6001adb14f794654ebfaf
+DIST path-16.2.0.tar.gz 45276 BLAKE2B 40b8eacc7e28398324f24b955adef11e5fc0bd512cd711cd3117f35a322ce0c3959b55255d4c96bbae64f914b5f3768088eb73fb45511c09f2e21bf99b3e9911 SHA512 f893d9fe3539eff0b43e4945076f770ffa7c3125151774d6accaa3a609fce351bc121562deb7ef695c0b1fc7aba12ce7487ae09a0b5daba2d5340586fc41ec79
diff --git a/dev-python/path-py/path-py-16.2.0.ebuild b/dev-python/path-py/path-py-16.2.0.ebuild
new file mode 100644
index 000000000000..611ebee5fa9f
--- /dev/null
+++ b/dev-python/path-py/path-py-16.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P="path-${PV}"
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}