summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-18 17:54:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-18 17:54:22 +0100
commitd5f3ecf140d1a61521ebcaaf0114d11cccc34654 (patch)
tree71ace1aac861f3babf621cf054e92de314740e94 /dev-python
parentdev-python/nbconvert: Bump to 7.13.0 (diff)
downloadgentoo-d5f3ecf140d1a61521ebcaaf0114d11cccc34654.tar.gz
gentoo-d5f3ecf140d1a61521ebcaaf0114d11cccc34654.tar.bz2
gentoo-d5f3ecf140d1a61521ebcaaf0114d11cccc34654.zip
dev-python/jupyter-core: Bump to 5.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter-core/Manifest1
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.5.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index d868459524a9..95f9c4f51a74 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-5.5.0.tar.gz 85369 BLAKE2B 41fa2381023c8f2313607d2ac989d1f35dcd362abd4b9573affaf9fc34cd48eb260d2ad68af97be2d47aa4a077f1756e6e291a4f0dd48c9774df2d31dda7e9b4 SHA512 92ca5ddc69d58ecdf1f707104e950ba43c88630991b0a6951fb6ba83260573b9f48c7903b25ae7bc105c08b3179de4bebb5a87b66453b96ceed631cbf555d631
+DIST jupyter_core-5.5.1.tar.gz 85962 BLAKE2B a00e96b417d86cc66ac483d031919483ded2e06da9688ed3554d96b5b6709f6ffd1d3602a63160d37c4774d37ee166aed3f3fb81f7f9882482302c8189a19fce SHA512 f82ce8a0f6671b06b6bb768d1a7cf85a9b28be57ba88809334d2fbcfed0d6e2bc5a2320a128ed8a8b498a763d157b1ecc1dc093de1c1aa97a65770a5b715c202
diff --git a/dev-python/jupyter-core/jupyter-core-5.5.1.ebuild b/dev-python/jupyter-core/jupyter-core-5.5.1.ebuild
new file mode 100644
index 000000000000..ff6b2a155d03
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.11.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest