summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 21:10:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 21:13:54 +0200
commitd643860ad6acd14b0916b534ac07d092b176db03 (patch)
treed8afedc93a6c3b289925bc0612357b004dfb1e16 /dev-python
parentdev-python/pycparser: Enable python3.10 (diff)
downloadgentoo-d643860ad6acd14b0916b534ac07d092b176db03.tar.gz
gentoo-d643860ad6acd14b0916b534ac07d092b176db03.tar.bz2
gentoo-d643860ad6acd14b0916b534ac07d092b176db03.zip
dev-python/cffi: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cffi/cffi-1.14.5.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/cffi/cffi-1.14.5.ebuild b/dev-python/cffi/cffi-1.14.5.ebuild
index 7aa72a4b5adf..d329f87995f8 100644
--- a/dev-python/cffi/cffi-1.14.5.ebuild
+++ b/dev-python/cffi/cffi-1.14.5.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# DO NOT ADD pypy to PYTHON_COMPAT
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1 toolchain-funcs
@@ -46,9 +46,8 @@ src_configure() {
python_test() {
"${EPYTHON}" -c "import _cffi_backend as backend" || die
- pytest -x -vv \
+ epytest \
--ignore testing/test_zintegration.py \
--ignore testing/embedding \
- c/ testing/ \
- || die "Testing failed with ${EPYTHON}"
+ c/ testing/
}