summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-03 07:40:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-03 08:19:07 +0100
commitd75085e837ed2ffcde65df0ccd0dd21a1916dfb0 (patch)
tree6e145c622dc8881b1106bab1ec40d6c123e2c071 /dev-python
parentsys-devel/clang-common: drop -fstack-clash-protection (diff)
downloadgentoo-d75085e837ed2ffcde65df0ccd0dd21a1916dfb0.tar.gz
gentoo-d75085e837ed2ffcde65df0ccd0dd21a1916dfb0.tar.bz2
gentoo-d75085e837ed2ffcde65df0ccd0dd21a1916dfb0.zip
dev-python/botocore: Bump to 1.29.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.63.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a97bc8492636..d22c6929022f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.29.59.gh.tar.gz 11131182 BLAKE2B fa85e1f8dc3c366f7a7fb3e9b06dd29
DIST botocore-1.29.60.gh.tar.gz 11129718 BLAKE2B 690d80fa12e9df141402019dc45ef2b0807669132ede8af6b57a45a172da78fda3de017a6392920885125763f221a1dbc6a406cb5cf85e66fb50916cc58ba15f SHA512 b8fb6567db599e09bc000ed0b178ff2799c45edeaf21b122a2028b83a50ef7aa27f874b8dec034f6dc61738c4fd3a218db92b26e104cfa2b3ed6f818d034108e
DIST botocore-1.29.61.gh.tar.gz 11137565 BLAKE2B 29cce274a1ded4bad0a841664e8b81d1d347ab0b2088c18f8c549463d6480edc795f6ec88571e5d0f0e453dcb5dff554027094072398022f38646ff81d73fd31 SHA512 3349fcf2859fe6d7f9e4cd901e80c8c2b856afb9b03e7967ab73a6888e6990767624cc462a338a17832687d279007c858047f69ceafbaf825a0b5fb468574c83
DIST botocore-1.29.62.gh.tar.gz 11139851 BLAKE2B 528dd2338ec4b1d9ab8f50d277f9dcec005fe5ce24045b06dfac4a856755a284076a92034c761d54dc5daeaa1a86cdcac3add3efb72d702e909b30a076976ec1 SHA512 a4691bbb9c02027d39b1471107e70843d135050e0e495e32bd223e45b587cd1bb91052a38885b99b063420e1ee73e121365adfe82c241f33fdfbfc722d098c7d
+DIST botocore-1.29.63.gh.tar.gz 11139461 BLAKE2B b05f6d52f55df9e456e80e9b701e2498c5fcdd2c65720719095e2c44b87acf854712a6cbc19e20a53b58b8075c8f20952605f60ed58cb1f99a6a771c61dac4d1 SHA512 7005db01c04d0eb2d94760ff1b7b89d28d956b310736dc5601b9e0bfd4b7ffeac6042a596f4f731b600e669a3fc74a7eededbe2bc0ef70d7d3a68f1d14149f9c
diff --git a/dev-python/botocore/botocore-1.29.63.ebuild b/dev-python/botocore/botocore-1.29.63.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.63.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}