summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-25 21:56:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-25 22:14:28 +0200
commitd8fbc11666cafe21f99568a9585105676a4a4b42 (patch)
treebf05b652df1cc31bfe00de14f7b29121fe09af55 /dev-python
parentdev-python/pytest-fixture-config: Port to py39 (diff)
downloadgentoo-d8fbc11666cafe21f99568a9585105676a4a4b42.tar.gz
gentoo-d8fbc11666cafe21f99568a9585105676a4a4b42.tar.bz2
gentoo-d8fbc11666cafe21f99568a9585105676a4a4b42.zip
dev-python/contextlib2: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild b/dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild
index 114a17add9f9..341b0e956fa5 100644
--- a/dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild
+++ b/dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
@@ -18,7 +18,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
IUSE="test"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? ( $(python_gen_cond_dep '
dev-python/unittest2[${PYTHON_USEDEP}]
' python2_7 pypy3