summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-20 18:14:30 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-20 21:10:42 +0100
commitd9789da7dd01c538dcf9b560ca14200fe2614ebd (patch)
treed4fc682615c59a54211db794ab04bbc1cd4d01c8 /dev-python
parentdev-python/pytest-xdist: Bump to 1.31.0 (diff)
downloadgentoo-d9789da7dd01c538dcf9b560ca14200fe2614ebd.tar.gz
gentoo-d9789da7dd01c538dcf9b560ca14200fe2614ebd.tar.bz2
gentoo-d9789da7dd01c538dcf9b560ca14200fe2614ebd.zip
dev-python/pytest: Bump to 4.6.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-4.6.8.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 84d8b5fd2bf0..51905c72edfd 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,6 +2,7 @@ DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4
DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c10faff221330ea0ae7482a2a7d0fb9443a0a264db00f1d92568d5a6005cb73e07d8643b46906f7ecff831adcb SHA512 cbffc6216f83491b1de241058315c116697bfaa5206b5f558192a7f861d43dd036d30d0d689bedae7bdee4f0258dd19ef5827c356e11863dd596a5fabe8249fc
DIST pytest-4.6.6.tar.gz 954899 BLAKE2B d3d76ec1fff18d343cc799f1acd0889489f303cdba72747881dfab8656599bc1865f01b5ad2754f0d05bda04aca4d7edf8c2071f2257fdf41506308d1bc0f623 SHA512 c5b6c21c352787eadce06be7529ecb6f6fd5f5eb193ec29e5a4cfff3d7e305f50c6f07aeac15bddce007d88077a35a8f59633111815321792ed3d9fa1011b684
DIST pytest-4.6.7.tar.gz 955616 BLAKE2B eb2276e715bab176fe4e497a51779d82b7146704749b33ebdc9dc07a0fcad144252553280a7bbbbcf23c6862fb74f1faf75de42ed0f5295ecd287fc10ac287a0 SHA512 d284cef48c0e39c901d23cd63949cc1d8b8cf01c3039fd2bfd99275bf6a45532c955e1176d556a7e2198e6206830e6dc4f4fb22c143ff7e08de6ffbfb6079fd1
+DIST pytest-4.6.8.tar.gz 956062 BLAKE2B f28e3226c7dfe4188168cfdf9623c96d0b274a2476f0d3132c24367e4566abd2e0b496114f229b6f26ae53a67d1ea1f9cb64795f4f9710fc9fe0852991467aef SHA512 b396b200a8a13ec9df8dbc4dd64bb05638b26af9ad6b24cbea3c3de4d806665b63a1488c7359b12c5634d014d45b43c8c208f0e329c62266882a87c492e80b58
DIST pytest-5.3.0.tar.gz 992537 BLAKE2B 4386d1623bdc168313a75847dfa33413ab1b6a4de9380c67ae866a579dbeb62d8cd18da899bf0476827d6e4a76ddfc5fee7a2fdc652eff0c8848c0bd96045c47 SHA512 285d0b4f6b87b141d6d5dac368dc46eb80dd025d7ed4ad0db937fcc76efc1f8cf251ca9b0786ab1bdadd89c07ad8ddd74f2b3496f97326e9d7fccfd004b98aff
DIST pytest-5.3.1.tar.gz 994584 BLAKE2B 3831902684d935389b4684af1279a5834edbbe846f8fdb1ce1e64990ab65d6fe8ed3cf5daa446cd20daafe9eedc6f57e01b16d74a55631ab746750a73056640d SHA512 e949a516c064a7050a0ad15356cc0bf25e4840e830f03e1925530c8a2dd9903d7632e55535894474422ba86fd9ed7a397c483d98dad297990b7b49456147189e
DIST pytest-5.3.2.tar.gz 995560 BLAKE2B aaea9d89e884a82056eeea3068c70604c73d50c96b8d78c6ee14c67bbe066f0e6d882c1b8f95539a2338d6739e047680d901a9db108b1923fa4d3d03dc3f2115 SHA512 2ab39973848d2d4693edd1dbd7ab2798b574026c9277bddd4a18e57aec65b3d93de201e87f58eb26030183b5c71818e6e56bcc1cda8c50892546cb1c04d6984a
diff --git a/dev-python/pytest/pytest-4.6.8.ebuild b/dev-python/pytest/pytest-4.6.8.ebuild
new file mode 100644
index 000000000000..4f85c1855b6c
--- /dev/null
+++ b/dev-python/pytest/pytest-4.6.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
+ -2 python3_{5,6,7} pypy3)
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2 python3_5)
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.0-strip-setuptools_scm.patch"
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # In v4.1.1, pytest started being picky about its own verbosity options.
+ # running pytest on itself with -vv made 3 tests fail. This is why we don't
+ # have it below.
+ "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}