summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-18 10:47:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-18 10:47:29 +0300
commitd98adae77d4d28f1b5d69097ea7c573e99128893 (patch)
tree5f30e5f65546f6bd2ef506d89321321158cd44d7 /dev-python
parentdev-python/charset_normalizer: add 2.0.4 (diff)
downloadgentoo-d98adae77d4d28f1b5d69097ea7c573e99128893.tar.gz
gentoo-d98adae77d4d28f1b5d69097ea7c573e99128893.tar.bz2
gentoo-d98adae77d4d28f1b5d69097ea7c573e99128893.zip
dev-python/setuptools_trial: enable py3.10, fix docs install
Closes: https://bugs.gentoo.org/802849 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild b/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
index 331289048c42..849cb00d85f1 100644
--- a/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
+++ b/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-DISTUTILS_USE_SETUPTOOLS=bdepend
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Setuptools plugin that makes unit tests execute with trial instead of pyunit"
@@ -22,7 +20,13 @@ RDEPEND="
>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}"
+BDEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -e '/data_files=/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
python_test() {
distutils_install_for_testing