summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-25 10:05:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-25 10:31:25 +0200
commitda2edca7bbb4afd4da0c2a253751804e76b9f656 (patch)
tree55db2f8fa2308ca9096cee3cdd0ca61a0d556f95 /dev-python
parentdev-python/virtualenv: Fix skipping tests on py2+pypy3 (diff)
downloadgentoo-da2edca7bbb4afd4da0c2a253751804e76b9f656.tar.gz
gentoo-da2edca7bbb4afd4da0c2a253751804e76b9f656.tar.bz2
gentoo-da2edca7bbb4afd4da0c2a253751804e76b9f656.zip
dev-python/virtualenv: Skip tests on py2 in 16*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.10.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/virtualenv/virtualenv-16.7.10.ebuild b/dev-python/virtualenv/virtualenv-16.7.10.ebuild
index 8bc31ec8ddd4..b8f4327d4e7d 100644
--- a/dev-python/virtualenv/virtualenv-16.7.10.ebuild
+++ b/dev-python/virtualenv/virtualenv-16.7.10.ebuild
@@ -26,14 +26,16 @@ RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]"
BDEPEND="${RDEPEND}
test? (
- >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' -3)
)"
DOCS=( docs/index.rst docs/changes.rst )
@@ -53,6 +55,11 @@ distutils_enable_sphinx docs \
dev-python/towncrier
python_test() {
+ if ! python_is_python3; then
+ ewarn "Tests are skipped on py2, please test externally"
+ return
+ fi
+
cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
die "Could not copy LICENSE.txt with ${EPYTHON}"