summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 18:09:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 18:25:57 +0100
commitdd66609e05adaa59d8d0b88313092b7291e3b145 (patch)
tree34f4793d2da1450c9729df9f40d4cf7ccefe439d /dev-python
parentdev-python/psycopg: Bump to 3.1.16 (diff)
downloadgentoo-dd66609e05adaa59d8d0b88313092b7291e3b145.tar.gz
gentoo-dd66609e05adaa59d8d0b88313092b7291e3b145.tar.bz2
gentoo-dd66609e05adaa59d8d0b88313092b7291e3b145.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index b935b3c6573f..5d3f6877e464 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1,2 +1,3 @@
DIST readthedocs-sphinx-ext-2.2.3.tar.gz 12176 BLAKE2B 9467e3d08baa15fe64ce0a718e922e4f8dc6c0bd76fd8a53f4bae66114bbd043bbcca71a2b7b152a162d7ca89b102668ccdc9ab9b0904e0caf2e0ff953fc489c SHA512 f8c9b2b62c73307906fc61a2dacc0c9079c1b81920718fbd2c60a45e22da7e581b9fa60aca83003081753603cb904187cae6075922a62616554c8fcc4c1d7991
DIST readthedocs-sphinx-ext-2.2.4.tar.gz 12474 BLAKE2B 1911f2a161d38c89b96d194bc5eaa1d015f2a9ef1350e9f01d50a2f575f8486618ae79f12b3b6a15a61ffe85a0c6d9f1f1560fa663ba1faa6aeda916a6cc9f05 SHA512 010116cb842cbf0a389d7e94196bf6122422584a843ff549d96384a8424f12458aec6493e412e28c9158082ca624fa2ff8d8cbbfc7d7c3e7e61aa69bef40c4b2
+DIST readthedocs-sphinx-ext-2.2.5.tar.gz 12303 BLAKE2B 55e67a96b8e5c4fef9d0768a4e514da924969628349d210b1cba6d8167c288bb4b6792486a80176fb01df7f8889b3f7b59ff30cb4ea487943e4bfe0d6942488f SHA512 d096803bb3d065236502d790ddd9efbf281854177dee7043f8bf2292cb124aea636b0d036e23ea3f23643484faaf2fd5e1b8636a2ed7973674cf5d5584f39bf3
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.5.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.5.ebuild
new file mode 100644
index 000000000000..00dffbb4b59c
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest