summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-04 08:28:17 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-04 10:54:08 +0200
commitde57766c4c54eb18df4b26796fb53ceb23505b1f (patch)
treec2d492c69a41cdbe10041bed61132e9d7d5bc2eb /dev-python
parentdev-java/netty-transport: remove unused patch(es) (diff)
downloadgentoo-de57766c4c54eb18df4b26796fb53ceb23505b1f.tar.gz
gentoo-de57766c4c54eb18df4b26796fb53ceb23505b1f.tar.bz2
gentoo-de57766c4c54eb18df4b26796fb53ceb23505b1f.zip
dev-python/httpx: fix testing timeouts
- Disable 2 tests that fail on all devboxes ({arm,ppc}{,64},sparc,x86,amd64,hppa) Those two are unimportant. - Increase timeout for one test that is too fast for hppa - Do small cleanup in ebuild Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/httpx/httpx-0.19.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/httpx/httpx-0.19.0.ebuild b/dev-python/httpx/httpx-0.19.0.ebuild
index dc9db3eda06c..4da735394292 100644
--- a/dev-python/httpx/httpx-0.19.0.ebuild
+++ b/dev-python/httpx/httpx-0.19.0.ebuild
@@ -41,19 +41,20 @@ BDEPEND="
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ # known to fail, unimportant test
+ "tests/test_decoders.py::test_text_decoder[data3-iso-8859-1]"
+ tests/models/test_responses.py::test_response_no_charset_with_iso_8859_1_content
+)
+
python_prepare_all() {
+ # increase timeout for slower systems
+ sed -e 's/pool=/&10*/' -i tests/test_timeouts.py || die
# trio does not support py3.10
- sed -i '/^import trio/d' tests/concurrency.py || die
- sed -i '/pytest.param("trio", marks=pytest.mark.trio)/d' tests/conftest.py || die
+ sed -e '/^import trio/d' -i tests/concurrency.py || die
+ sed -e '/pytest.param("trio", marks=pytest.mark.trio)/d' -i tests/conftest.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- local deselect=(
- # Internet
- tests/client/test_proxies.py::test_async_proxy_close
- tests/client/test_proxies.py::test_sync_proxy_close
- )
-
- epytest ${deselect[@]/#/--deselect }
-}