summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-08-14 11:16:20 +0200
committerPacho Ramos <pacho@gentoo.org>2022-08-14 11:16:20 +0200
commite339a4c433c84550ea18fa5ff61c1db7e7e4ee2c (patch)
tree935fc787efa41bc97f90f54ee613c53f2866f03d /dev-python
parentx11-themes/papirus-icon-theme: add 20220808 (diff)
downloadgentoo-e339a4c433c84550ea18fa5ff61c1db7e7e4ee2c.tar.gz
gentoo-e339a4c433c84550ea18fa5ff61c1db7e7e4ee2c.tar.bz2
gentoo-e339a4c433c84550ea18fa5ff61c1db7e7e4ee2c.zip
dev-python/nototools: add 0.2.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nototools/Manifest1
-rw-r--r--dev-python/nototools/nototools-0.2.17.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nototools/Manifest b/dev-python/nototools/Manifest
index ab1afd09bcd2..06697292a2d7 100644
--- a/dev-python/nototools/Manifest
+++ b/dev-python/nototools/Manifest
@@ -1 +1,2 @@
DIST nototools-0.2.16.tar.gz 9712796 BLAKE2B 654f449a00741dfa4a9b3b8c2a80d40907698098d1c4ee94363657d88b24fe1f26287af5e7795484846d394573a868ff82fa9a8c0a51b953325d6f6f97d7f7c8 SHA512 3c70c29f8411ae3eedc2738e0b2f42f9c0b675494bbdc107a8b43612fba08401c704ec94db63bb92aa1648b168f9e0d9e8139b8c61dc3b43973876d105324554
+DIST nototools-0.2.17.tar.gz 9743805 BLAKE2B ba601b4c9c4df7fc264dd88c60e50c1db08c21bc07f3ab408f91f445a801bd96ed193e5f9cb320378f6411027b1be004d718233d531bb2ec600badfaffd2d876 SHA512 a5b733c47ce61f6cb18f9772e8fee04f8ee2a3d834afa3f71a5f1c8110124224b9d325db75976104dd880b7c0538568574b2e497faa8f4d5541451e9c3e40cd3
diff --git a/dev-python/nototools/nototools-0.2.17.ebuild b/dev-python/nototools/nototools-0.2.17.ebuild
new file mode 100644
index 000000000000..f46efa64256c
--- /dev/null
+++ b/dev-python/nototools/nototools-0.2.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="notofonttools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlefonts/nototools"
+#SRC_URI="https://github.com/googlefonts/nototools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=media-gfx/scour-0.37
+ >=dev-python/booleanOperations-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/defcon-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Some tests weren't ported to python3 yet and lots of failures
+RESTRICT="test"
+
+distutils_enable_tests setup.py