summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 21:24:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:44 -0500
commite587e368e282d61d1a93abe9222a34ab623c797b (patch)
tree3ff3a832d75d5f12492fc5733a2d141ed47044b0 /dev-python
parentdev-python/oslo-log: 3.30.0 bup (diff)
downloadgentoo-e587e368e282d61d1a93abe9222a34ab623c797b.tar.gz
gentoo-e587e368e282d61d1a93abe9222a34ab623c797b.tar.bz2
gentoo-e587e368e282d61d1a93abe9222a34ab623c797b.zip
dev-python/alembic: 0.9.3 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-0.9.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 9e3d38cbbca0..6546f109fced 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-0.8.10.tar.gz 976028 SHA256 0e3b50e96218283ec7443fb661199f5a81f5879f766967a8a2d25e8f9d4e7919 SHA512 28456eb41a2b2d0d870f34cfddf46c25ed01fd1ee99b1a3697e6c0c5369f49245e54db0d7232cc839cf03a5c48efb48a8b967586b3a81ba9462b485b6782a415 WHIRLPOOL 7aeac48eb5fa81c91bfbf9c601875fe3329f1f899f5c20321574bc7141f82aa4dee8c7388cad67d28f6a13ad5d016a14beb7e84386f8a641d10c00cec1839cb1
+DIST alembic-0.9.3.tar.gz 991744 SHA256 57f2ede554c0b18f1cf811cfbb3b02c586a5422df94922e3821883ba0b8c616c SHA512 1f39521a1cc9e1e8f8d344f2e48e1f656aed2ffda8e0608b9c5a9a7a1f0e4d16865ae0fba903023512a198afc70e72c683b0ff2bd1bc2e9ba6667009e940a63e WHIRLPOOL 3ffc0bac46b4e0e89fa1e2afff2c1f2a6df5f9e3e9af3a4245ea4d048024b7b34896910db79d7bfc7be73fa9cb182d8a52425b67d5f57402984b6f3db39dc085
diff --git a/dev-python/alembic/alembic-0.9.3.ebuild b/dev-python/alembic/alembic-0.9.3.ebuild
new file mode 100644
index 000000000000..d031f72bfdea
--- /dev/null
+++ b/dev-python/alembic/alembic-0.9.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}