summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:50:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:59:05 -0600
commite5c719370dc5ec2e904eb363f6cbcef6488f645a (patch)
treedc0b8c79d8027f399f85b3acf44378cfb3263f98 /dev-python
parentdev-python/castellan: 0.17.0 bup (diff)
downloadgentoo-e5c719370dc5ec2e904eb363f6cbcef6488f645a.tar.gz
gentoo-e5c719370dc5ec2e904eb363f6cbcef6488f645a.tar.bz2
gentoo-e5c719370dc5ec2e904eb363f6cbcef6488f645a.zip
dev-python/google-api-python-client: 1.6.5 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 2486dc95f16e..d46cbcf264b9 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-1.5.3.tar.gz 3622355 BLAKE2B 1187729581c9e852a4512fdfd557785791c8102d6796f6d02d212820f9fe89393574ffbedc1445416ff2fa876269f18adb162a33241f6331e989a31ccafec60d SHA512 3f58af0d1f165fa7e045d08a0bfc282855b40dbea16d310bbc4cbce76f631b6303738a396048efc8ea114fdff1164d1ad303148999d0ab0ba0d2cc91df9408b3
DIST google-api-python-client-1.6.2.tar.gz 4262337 BLAKE2B 0ae3e5b1c6bbb80999cfaadaef7812bb53d03eb1160f79a29bf73a180dae40bd2c5e7dceff0badaf5eda44718a06c4ec65fe993896a82c5fd12348f810ec2812 SHA512 ee906c2efb47469dc18dcfcb1edfad4346f61e88c1e7f73b60924b393c704e7033a5ff4f9a1965d0c29aa3a6bf25b60888e1d39366cbc1372861b49e79c9e886
+DIST google-api-python-client-1.6.5.tar.gz 4255929 BLAKE2B 4e2197fe56f25cd202f7a0b3f64b3796158d798bfedb9c0690a59c24bd5ce10fbe0300093ebb76cd343dae5eea2a0a360903cd0890834241926fd55a7dc07ea9 SHA512 b2f2be81e6f54ee3065e75ea064ea3ae49cb983d401ac46dca8459409dbd6df7c3ba07798285b5177bfa632a20d43aaaef3a7c73d5d565796567b8b305737565
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild
new file mode 100644
index 000000000000..6b96fa2281f9
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}