summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 17:33:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-20 15:43:47 +0200
commite63874eb81c33759266f9f3aa5158248c52204b9 (patch)
tree2aaf4e0d5d61f1815598028ef7ce87d4995dd760 /dev-python
parentprofiles: amd64-fbsd: Mask dev-python/soappy[ssl] (diff)
downloadgentoo-e63874eb81c33759266f9f3aa5158248c52204b9.tar.gz
gentoo-e63874eb81c33759266f9f3aa5158248c52204b9.tar.bz2
gentoo-e63874eb81c33759266f9f3aa5158248c52204b9.zip
dev-python/m2crypto: Drop old
Broken by >=OpenSSL-1.1. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/files/m2crypto-libressl-version-check.patch154
-rw-r--r--dev-python/m2crypto/m2crypto-0.24.0.ebuild38
-rw-r--r--dev-python/m2crypto/m2crypto-0.27.0-r2.ebuild56
-rw-r--r--dev-python/m2crypto/m2crypto-0.27.0.ebuild52
-rw-r--r--dev-python/m2crypto/m2crypto-0.31.0-r1.ebuild56
6 files changed, 0 insertions, 358 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index f6a0ec6a2523..7e9058b257cd 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,3 +1 @@
-DIST M2Crypto-0.24.0.tar.gz 184457 BLAKE2B 15a11dc1b13359041875e8321d0159a1a393b7f85dfbd38d650721d8a2eaed2cc2199859c3e1e3c890033711e0b137f4c78b90f04681ff44a3356558b9f55aea SHA512 c23ae0f8ac790d4ef108a217a44e994341f6bbe4e12a7fef2518d8def82331246a145e19a2504b82b790a3ad4b467d2facc8a73bb7f1190b56441d8482c66aca
-DIST M2Crypto-0.27.0.tar.gz 1119288 BLAKE2B 90e227aef9a5b4c7f5ab9bd62fbe506ea0931a6c338c530adbeb1a8303a31cc7755d13003532fe0ee4005f1997db23bed2d03cd54224dc7d89a6f23882197800 SHA512 df0f6b16f7d00a19fafbb5da5a3ececff6b4627accd00ca65e0d6f9e752a97f41016d0072c8e681475fe1d87c89b7474067068c0bfce6c68a30baddeb31bfac2
DIST M2Crypto-0.31.0.tar.gz 1292016 BLAKE2B 3f1e0e8f686719ff87fa3a51cdc287be989fa1554866582deb1968fd04605270e14cbfd280f64211c043c5d8cb77a09e6a8cec6824ab15416ab94366aa73d2a3 SHA512 9f3e2afda4b8ac14aa64a1534e446eb6895ec7182ce5b7ded8008178e01139d383561a87f8c9fb5fe4b9c257ba5c6b93339955eb9e2f7417cd3f4832c35c4598
diff --git a/dev-python/m2crypto/files/m2crypto-libressl-version-check.patch b/dev-python/m2crypto/files/m2crypto-libressl-version-check.patch
deleted file mode 100644
index 770c49f42782..000000000000
--- a/dev-python/m2crypto/files/m2crypto-libressl-version-check.patch
+++ /dev/null
@@ -1,154 +0,0 @@
---- a/SWIG/_bio.i
-+++ b/SWIG/_bio.i
-@@ -63,14 +63,14 @@ extern BIO *BIO_pop(BIO *);
- static PyObject *_bio_err;
-
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- void pyfd_init(void);
- #endif
-
- void bio_init(PyObject *bio_err) {
- Py_INCREF(bio_err);
- _bio_err = bio_err;
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- pyfd_init();
- #endif
- }
-@@ -299,7 +299,7 @@ int bio_should_write(BIO* a) {
- return BIO_should_write(a);
- }
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- /* implment custom BIO_s_pyfd */
-
- #ifdef WIN32
-
---- a/SWIG/_evp.i
-+++ b/SWIG/_evp.i
-@@ -19,7 +19,7 @@ Copyright (c) 2009-2010 Heikki Toivonen. All rights reserved.
- #include <openssl/rsa.h>
- #include <openssl/opensslv.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- HMAC_CTX *HMAC_CTX_new(void) {
- HMAC_CTX *ret = PyMem_Malloc(sizeof(HMAC_CTX));
-
---- a/SWIG/_lib.i
-+++ b/SWIG/_lib.i
-@@ -18,7 +18,7 @@
-
- %{
- /* OpenSSL 1.0.2 copmatbility shim */
--#if OPENSSL_VERSION_NUMBER < 0x10002000L
-+#if OPENSSL_VERSION_NUMBER < 0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
- typedef void (*OPENSSL_sk_freefunc)(void *);
- typedef void *(*OPENSSL_sk_copyfunc)(const void *);
- typedef struct stack_st OPENSSL_STACK;
-@@ -501,7 +501,7 @@ int passphrase_callback(char *buf, int num, int v, void *arg) {
- %inline %{
-
- void lib_init() {
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- SSLeay_add_all_algorithms();
- ERR_load_ERR_strings();
- #endif
-
---- a/SWIG/_lib11_compat.i
-+++ b/SWIG/_lib11_compat.i
-@@ -8,7 +8,7 @@
- */
-
- %{
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- #include <string.h>
- #include <openssl/engine.h>
-
---- a/SWIG/_ssl.i
-+++ b/SWIG/_ssl.i
-@@ -268,7 +268,7 @@ void ssl_init(PyObject *ssl_err, PyObject *ssl_timeout_err) {
-
- #ifndef OPENSSL_NO_SSL3
- const SSL_METHOD *sslv3_method(void) {
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- PyErr_WarnEx(PyExc_DeprecationWarning,
- "Function SSLv3_method has been deprecated.", 1);
- #endif
-@@ -277,7 +277,7 @@ const SSL_METHOD *sslv3_method(void) {
- #endif
-
- const SSL_METHOD *tlsv1_method(void) {
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- PyErr_WarnEx(PyExc_DeprecationWarning,
- "Function TLSv1_method has been deprecated.", 1);
- #endif
-
---- a/SWIG/_threads.i
-+++ b/SWIG/_threads.i
-@@ -5,7 +5,7 @@
- #include <pythread.h>
- #include <openssl/crypto.h>
-
--#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #define CRYPTO_num_locks() (CRYPTO_NUM_LOCKS)
- static PyThread_type_lock lock_cs[CRYPTO_num_locks()];
- static long lock_count[CRYPTO_num_locks()];
-@@ -13,7 +13,7 @@ static int thread_mode = 0;
- #endif
-
- void threading_locking_callback(int mode, int type, const char *file, int line) {
--#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- if (mode & CRYPTO_LOCK) {
- PyThread_acquire_lock(lock_cs[type], WAIT_LOCK);
- lock_count[type]++;
-@@ -25,7 +25,7 @@ void threading_locking_callback(int mode, int type, const char *file, int line)
- }
-
- unsigned long threading_id_callback(void) {
--#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- return (unsigned long)PyThread_get_thread_ident();
- #else
- return (unsigned long)0;
-@@ -35,7 +35,7 @@ unsigned long threading_id_callback(void) {
-
- %inline %{
- void threading_init(void) {
--#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- int i;
- if (!thread_mode) {
- for (i=0; i<CRYPTO_num_locks(); i++) {
-@@ -50,7 +50,7 @@ void threading_init(void) {
- }
-
- void threading_cleanup(void) {
--#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if defined(THREADING) && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- int i;
- if (thread_mode) {
- CRYPTO_set_locking_callback(NULL);
-
---- a/SWIG/libcrypto-compat.h
-+++ b/SWIG/libcrypto-compat.h
-@@ -1,7 +1,7 @@
- #ifndef LIBCRYPTO_COMPAT_H
- #define LIBCRYPTO_COMPAT_H
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- #include <openssl/rsa.h>
- #include <openssl/dsa.h>
diff --git a/dev-python/m2crypto/m2crypto-0.24.0.ebuild b/dev-python/m2crypto/m2crypto-0.24.0.ebuild
deleted file mode 100644
index 6fa7deaa9ba1..000000000000
--- a/dev-python/m2crypto/m2crypto-0.24.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="M2Crypto"
-
-DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="libressl"
-
-RDEPEND="
- !libressl? ( >=dev-libs/openssl-0.9.8:0= )
- libressl? ( dev-libs/libressl:= )
-"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-1.3.28:0
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# Tests access network, and fail randomly. Bug #431458.
-RESTRICT=test
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/m2crypto/m2crypto-0.27.0-r2.ebuild b/dev-python/m2crypto/m2crypto-0.27.0-r2.ebuild
deleted file mode 100644
index 84bdf24cfb7d..000000000000
--- a/dev-python/m2crypto/m2crypto-0.27.0-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="M2Crypto"
-
-DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-IUSE="libressl"
-
-RDEPEND="
- !libressl? ( >=dev-libs/openssl-0.9.8:0=[-bindist(-)] )
- libressl? ( dev-libs/libressl:0= )
- virtual/python-typing[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-1.3.28:0
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# Tests access network, and fail randomly. Bug #431458.
-RESTRICT=test
-
-PATCHES=(
- "${FILESDIR}/${PN}-libressl-version-check.patch"
-)
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- # https://bugs.gentoo.org/617946
- # TODO: Fix cross-compiles
- local -x SWIG_FEATURES=
- case ${ABI} in
- x32) SWIG_FEATURES="-D__ILP32__" ;;
- esac
- distutils-r1_python_compile --openssl="${EPREFIX}"/usr
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/m2crypto/m2crypto-0.27.0.ebuild b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
deleted file mode 100644
index e1df10b50d73..000000000000
--- a/dev-python/m2crypto/m2crypto-0.27.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="M2Crypto"
-
-DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-IUSE="libressl"
-
-RDEPEND="
- !libressl? ( >=dev-libs/openssl-0.9.8:0=[-bindist(-)] )
- libressl? ( dev-libs/libressl:0= )
- virtual/python-typing[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-1.3.28:0
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# Tests access network, and fail randomly. Bug #431458.
-RESTRICT=test
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- # https://bugs.gentoo.org/617946
- # TODO: Fix cross-compiles
- local -x SWIG_FEATURES=
- case ${ABI} in
- x32) SWIG_FEATURES="-D__ILP32__" ;;
- esac
- distutils-r1_python_compile --openssl="${EPREFIX}"/usr
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/m2crypto/m2crypto-0.31.0-r1.ebuild b/dev-python/m2crypto/m2crypto-0.31.0-r1.ebuild
deleted file mode 100644
index a3aab5c0c9ac..000000000000
--- a/dev-python/m2crypto/m2crypto-0.31.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2018-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5..7})
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="M2Crypto"
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-IUSE="libressl"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0=[-bindist(-)] )
- libressl? ( dev-libs/libressl:0= )
- virtual/python-typing[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2.0.9
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# Tests access network, and fail randomly. Bug #431458.
-RESTRICT=test
-
-PATCHES=(
- "${FILESDIR}/${PN}-libressl-${PV}.patch"
-)
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- # https://bugs.gentoo.org/617946
- # TODO: Fix cross-compiles
- local -x SWIG_FEATURES=
- case ${ABI} in
- x32) SWIG_FEATURES="-D__ILP32__" ;;
- esac
- distutils-r1_python_compile --openssl="${EPREFIX}"/usr
-}
-
-python_test() {
- esetup.py test
-}