summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 16:50:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 16:50:39 +0100
commite658428e166eafb19b370d0d5eccd4dd96fbd0b3 (patch)
treeff4d68dfbc7034a66bdb22531714f5b1fa3097d6 /dev-python
parentdev-python/virtualenvwrapper: Remove old (diff)
downloadgentoo-e658428e166eafb19b370d0d5eccd4dd96fbd0b3.tar.gz
gentoo-e658428e166eafb19b370d0d5eccd4dd96fbd0b3.tar.bz2
gentoo-e658428e166eafb19b370d0d5eccd4dd96fbd0b3.zip
dev-python/zeep: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeep/Manifest2
-rw-r--r--dev-python/zeep/files/zeep-4.1.0-cached-prop.patch100
-rw-r--r--dev-python/zeep/zeep-4.1.0-r2.ebuild57
-rw-r--r--dev-python/zeep/zeep-4.2.0.ebuild53
4 files changed, 0 insertions, 212 deletions
diff --git a/dev-python/zeep/Manifest b/dev-python/zeep/Manifest
index 5eba0b34e497..c03ab549db08 100644
--- a/dev-python/zeep/Manifest
+++ b/dev-python/zeep/Manifest
@@ -1,3 +1 @@
-DIST zeep-4.1.0.tar.gz 160333 BLAKE2B d29db92efe048ba854ff14cde062993c3f334cab6cfc122f6db9aa7a1a490c82f93a50ca5028a5f86e316d9ecf567ac40aef10f3e7d8db89376c7d8dea2a2e23 SHA512 acc54f99d21fe401e06418223591bcf8e7f8819e225f892beb0f6e2a1ee359a0da6f9d0aa4212899197c084af37cc56126879b93a22cdad2458e57674bf66ed5
-DIST zeep-4.2.0.tar.gz 161102 BLAKE2B e6d25ec10c1e50d6d3e029d65e0ec28ca70524b82ba67c261099fa970cbb0af320e9085539316ae64736600acce0e69793c081314c01e2de34a026208d8a5bef SHA512 dd7ea6fb80e41ae0ed81ebc26b9d0498685c9801baf0c46c124b0341e78127f521e429c7b55a2056018f3229128294f2715f8794ae8c00f313435cd8663c63f6
DIST zeep-4.2.1.tar.gz 161072 BLAKE2B 01e3ec848bc4a98b301b7d091a0740f4a69057f3bb56e884a31b1d73ed51b0c62b4e0e148b2a59ebb6f01469aa949cb4079c0147dae7b3d8e7c8a2f66e5b31f8 SHA512 08de88c1e4cd1787137ea18f12bf343c5c9bb7b353ecd8781c58c7c1acf1b6ee8a0483b47d9a78eb24c79d8ecc347eb8595d460d9f75ca0428963f36a76dff5d
diff --git a/dev-python/zeep/files/zeep-4.1.0-cached-prop.patch b/dev-python/zeep/files/zeep-4.1.0-cached-prop.patch
deleted file mode 100644
index 368dca71ad38..000000000000
--- a/dev-python/zeep/files/zeep-4.1.0-cached-prop.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 25701f0b69ee46914179070b7e8906ea3e521480 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 11 Nov 2021 08:55:41 +0100
-Subject: [PATCH] Use stdlib functools.cached_property if available
-
-Python 3.8+ provides a functools.cached_property in the stdlib that is
-thread-safe, i.e. equivalent to threaded_cached_property. Use it
-instead of adding third-party dependencies whenever available.
----
- setup.py | 2 +-
- src/zeep/wsdl/attachments.py | 6 +++++-
- src/zeep/xsd/elements/indicators.py | 6 +++++-
- src/zeep/xsd/types/any.py | 6 +++++-
- src/zeep/xsd/types/complex.py | 6 +++++-
- 5 files changed, 21 insertions(+), 5 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index cb51ac4..8ef81b6 100755
---- a/setup.py
-+++ b/setup.py
-@@ -4,7 +4,7 @@ from setuptools import setup
-
- install_requires = [
- "attrs>=17.2.0",
-- "cached-property>=1.3.0",
-+ "cached-property>=1.3.0; python_version<'3.8'",
- "isodate>=0.5.4",
- "lxml>=4.6.0",
- "platformdirs>=1.4.0",
-diff --git a/src/zeep/wsdl/attachments.py b/src/zeep/wsdl/attachments.py
-index 037e439..075bee5 100644
---- a/src/zeep/wsdl/attachments.py
-+++ b/src/zeep/wsdl/attachments.py
-@@ -6,7 +6,11 @@ See https://www.w3.org/TR/SOAP-attachments
-
- import base64
-
--from cached_property import cached_property
-+try:
-+ from functools import cached_property
-+except ImportError:
-+ from cached_property import cached_property
-+
- from requests.structures import CaseInsensitiveDict
-
-
-diff --git a/src/zeep/xsd/elements/indicators.py b/src/zeep/xsd/elements/indicators.py
-index 40325da..e9ef2c4 100644
---- a/src/zeep/xsd/elements/indicators.py
-+++ b/src/zeep/xsd/elements/indicators.py
-@@ -16,7 +16,11 @@ import operator
- import typing
- from collections import OrderedDict, defaultdict, deque
-
--from cached_property import threaded_cached_property
-+try:
-+ from functools import cached_property as threaded_cached_property
-+except ImportError:
-+ from cached_property import threaded_cached_property
-+
- from lxml import etree
-
- from zeep.exceptions import UnexpectedElementError, ValidationError
-diff --git a/src/zeep/xsd/types/any.py b/src/zeep/xsd/types/any.py
-index b4525e4..17f244e 100644
---- a/src/zeep/xsd/types/any.py
-+++ b/src/zeep/xsd/types/any.py
-@@ -1,7 +1,11 @@
- import logging
- import typing
-
--from cached_property import threaded_cached_property
-+try:
-+ from functools import cached_property as threaded_cached_property
-+except ImportError:
-+ from cached_property import threaded_cached_property
-+
- from lxml import etree
-
- from zeep.utils import qname_attr
-diff --git a/src/zeep/xsd/types/complex.py b/src/zeep/xsd/types/complex.py
-index 8141bc1..b2ed9bf 100644
---- a/src/zeep/xsd/types/complex.py
-+++ b/src/zeep/xsd/types/complex.py
-@@ -4,7 +4,11 @@ import typing
- from collections import OrderedDict, deque
- from itertools import chain
-
--from cached_property import threaded_cached_property
-+try:
-+ from functools import cached_property as threaded_cached_property
-+except ImportError:
-+ from cached_property import threaded_cached_property
-+
- from lxml import etree
-
- from zeep.exceptions import UnexpectedElementError, XMLParseError
---
-2.33.1
-
diff --git a/dev-python/zeep/zeep-4.1.0-r2.ebuild b/dev-python/zeep/zeep-4.1.0-r2.ebuild
deleted file mode 100644
index a04730a0cc9e..000000000000
--- a/dev-python/zeep/zeep-4.1.0-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
-HOMEPAGE="https://docs.python-zeep.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="async"
-
-RDEPEND="
- >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
- >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/aioresponses[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/python-xmlsec[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-cached-prop.patch
-)
-
-EPYTEST_DESELECT=(
- # broken by new pytest-httpx?
- tests/test_async_transport.py::test_load
- tests/test_async_transport.py::test_load_cache
- tests/test_async_transport.py::test_post
- tests/test_async_transport.py::test_http_error
-)
diff --git a/dev-python/zeep/zeep-4.2.0.ebuild b/dev-python/zeep/zeep-4.2.0.ebuild
deleted file mode 100644
index adcaf749a07b..000000000000
--- a/dev-python/zeep/zeep-4.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
-HOMEPAGE="https://docs.python-zeep.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="async"
-
-RDEPEND="
- >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
- >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/aioresponses[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/python-xmlsec[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # broken by new pytest-httpx?
- tests/test_async_transport.py::test_load
- tests/test_async_transport.py::test_load_cache
- tests/test_async_transport.py::test_post
- tests/test_async_transport.py::test_http_error
-)