summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-09-03 00:12:09 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-09-29 13:26:00 +0300
commite7705c8d44d861c03028fcd767bfb2994134e5ff (patch)
treed028d19e2b734395b3b77d0ec13d4db5375c4304 /dev-python
parentapp-editors/neovim: gcc-10 fix for 0.4.3 (diff)
downloadgentoo-e7705c8d44d861c03028fcd767bfb2994134e5ff.tar.gz
gentoo-e7705c8d44d861c03028fcd767bfb2994134e5ff.tar.bz2
gentoo-e7705c8d44d861c03028fcd767bfb2994134e5ff.zip
dev-python/neovim-remote: version bump to 2.4.0
Closes: https://bugs.gentoo.org/738018 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/17391 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.4.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
index 9484816847be..eef6d19f080c 100644
--- a/dev-python/neovim-remote/Manifest
+++ b/dev-python/neovim-remote/Manifest
@@ -1 +1,2 @@
DIST neovim-remote-2.2.1.tar.gz 438078 BLAKE2B abbb056a10acb1c4e21c0c418ee2d6003869340eb34df0c0374b947fbbfa2d2e0f64f61ad571a6cad7ffad7374f1df17a519795e61b37b8d6741d566760759e9 SHA512 04a16a1ed5f4947b4fd763432a14fc565300abe9b480037a462f0c4700535d4854012ff08ac64234dbb1fccc1d3f5ba2174f94effc5564879fbcd1c83fee26ae
+DIST neovim-remote-2.4.0.tar.gz 438687 BLAKE2B 0dfbe3d660d9b2f6b7a4f1016d4d230d63612306ea99079364ed5c6dbae51df7a19c4d1bca51a7bfad142ffe5811e286b843edf6b0715c7aac921c584701030e SHA512 073bf95a0238c76c19258d886fe71e23ec85f9cba200b8a490014a2842d1a84b3c95092afcfdcc8ca80122639b9e07652594faa24ed6a6aff537192ec3a3d14c
diff --git a/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild b/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild
new file mode 100644
index 000000000000..0516b6e481b5
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pynvim[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ app-editors/neovim
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest -vv || die
+}