summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:07:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:18:52 +0100
commiteafb078319ee982aa7a0163177a8555df3555791 (patch)
tree6825abf85088d50b95b4df12be7b6b035421ddb8 /dev-python
parentdev-python/pylibacl: Bump to 0.6.0 (diff)
downloadgentoo-eafb078319ee982aa7a0163177a8555df3555791.tar.gz
gentoo-eafb078319ee982aa7a0163177a8555df3555791.tar.bz2
gentoo-eafb078319ee982aa7a0163177a8555df3555791.zip
dev-python/xcffib: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.11.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 0c5407592166..21988535e76d 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1 +1,2 @@
DIST xcffib-0.10.1.tar.gz 84689 BLAKE2B e36ad4f9c6bf5bc63400ae35d0d58ea1def00f299c0f811807cde430e6a6850132e77584359f77fb2f4ce5fdf5f22ec91ed22e1b7ce5d6d318b7a8dc5f3e0939 SHA512 98412fe36962108902dc0599f05ac9be5d7412d7f12fc6566e020c2ce84ae4a536a20ae2dfddd2dc9a536f37cd82539bf19e1993ee65f0b09c44372008cd7edf
+DIST xcffib-0.11.0.tar.gz 84750 BLAKE2B adc1faebc8f0e83150f50e1b711175f5f4617124e07a4d5744b7d1c116cdb89f6d68617cc0ad0efccf2d9465e6bbd2504ee08c322c61228728aeeccb57fe55fa SHA512 22b82844295b277e2abb363ff818e7163037542ffc1ec2874a948f3b3cc63e9a8fad371fa87099910546a17f2f6f1bfb8f62214869fa30a196fc198adce14384
diff --git a/dev-python/xcffib/xcffib-0.11.0.ebuild b/dev-python/xcffib/xcffib-0.11.0.ebuild
new file mode 100644
index 000000000000..790a52834b15
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.11.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+distutils_enable_tests nose