summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 08:35:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 09:22:30 +0200
commited7777865b9c73f75208371926bd095629357f05 (patch)
treec5bf79bcf25892e027349573069518fb5348941b /dev-python
parentdev-python/emoji: Bump to 2.0.0 (diff)
downloadgentoo-ed7777865b9c73f75208371926bd095629357f05.tar.gz
gentoo-ed7777865b9c73f75208371926bd095629357f05.tar.bz2
gentoo-ed7777865b9c73f75208371926bd095629357f05.zip
dev-python/nose2: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.12.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index c3f11170361b..9034b135ccb0 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.11.0.tar.gz 159486 BLAKE2B 36167e492a49017e0f1474bfd5fd77782a324f7d884bc11c88cf9226090dce67d47519db00d3b57542dc808fb0db40942184b3c1804ad3923e3cf5fc03cd50bc SHA512 8e6755c0f5a25c4c53a35d93e5c7988523e03e978b0593d49b7917dfcb980553be9af0cc3c67c2db527c304d049d97a8d7f6f53b1a8b2875ab5456cbb7519375
+DIST nose2-0.12.0.gh.tar.gz 168454 BLAKE2B cce76a046c4285d7dbe6ad6a049628e23ddebd36eda4457eecb4f0e14b1559f8bd7be5bc80aa99bf965f530575c3f5e245d1a30b4115d5e8ee0aa4c8d93fb8f0 SHA512 7f1462613b7d38a77cd0764f721be4223b8f4ae4694c49ba416a076c321e07484969ee1a7c2d2f89484c0c3b2a96e74d6a42321981af4930ebe5f63f07df7755
diff --git a/dev-python/nose2/nose2-0.12.0.ebuild b/dev-python/nose2/nose2-0.12.0.ebuild
new file mode 100644
index 000000000000..67a1e62433f1
--- /dev/null
+++ b/dev-python/nose2/nose2-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+SRC_URI="
+ https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ # seriously? that hard to depend on six?!
+ rm -r nose2/_vendor || die
+ find -name '*.py' -exec \
+ sed -i -e 's:from nose2._vendor ::' {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}